Opened 7 years ago

Last modified 5 years ago

#8344 new bug

SSD in Acer W500 isn't recognised

Reported by: lxstoian Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: Acer, W500, SATA Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The ssd in my Acer W500 tablet isn't recognised.

Attachments (4)

listdev.txt (3.5 KB) - added by lxstoian 7 years ago.
listusb.txt (973 bytes) - added by lxstoian 7 years ago.
syslog.txt (448.3 KB) - added by lxstoian 7 years ago.
syslog new.txt (321.0 KB) - added by lxstoian 7 years ago.

Download all attachments as: .zip

Change History (16)

Changed 7 years ago by lxstoian

Attachment: listdev.txt added

Changed 7 years ago by lxstoian

Attachment: listusb.txt added

Changed 7 years ago by lxstoian

Attachment: syslog.txt added

comment:1 Changed 7 years ago by X512

Keywords: Acer W500 added

comment:2 Changed 7 years ago by X512

I successfully installed Haiku on this device one month ago and don't saw any problem with disk or multiboot. Now I uninstall because of #8338. Work with external mouse is unpractical.

comment:3 Changed 7 years ago by lxstoian

I have tested hrev43824 and still the same problem. Haiku wont see my ssd.

comment:4 Changed 7 years ago by X512

Strange... I test hrev43826 on Acer W500 and SDD are recognized. Can you show screenshot of DriveSetup?

Last edited 7 years ago by X512 (previous) (diff)

comment:5 Changed 7 years ago by korli

Component: - GeneralDrivers/Disk
Owner: changed from nobody to marcusoverhagen

The syslog seems to indicate a problem with ATA/AHCI.

comment:6 Changed 7 years ago by marcusoverhagen

Indeed, but to locate the problem, a syslog with timestamps turned on would be useful.

comment:7 Changed 7 years ago by lxstoian

Will provide one soon.

Changed 7 years ago by lxstoian

Attachment: syslog new.txt added

comment:8 Changed 7 years ago by lxstoian

Here it is.

comment:9 Changed 7 years ago by lxstoian

This bug is still present in the latest builds both on the Acer w500 and Asus 1215b , but more worryingly I tested Haiku on another AMD APU laptop (E-300) and the bug is also present. It seems Haiku wont see the Hardisk or SSD on any of the new AMD APU devices.

comment:10 Changed 6 years ago by X512

Sometimes I got no boot partitions error and no SDD in DriveSetup too. It happens randomly.

comment:11 Changed 5 years ago by X512

This issue can be related to SATA driver. I found option in BIOS that change disk access from SATA to IDE and now internal drive is recognized every boot without problems.

comment:12 Changed 5 years ago by X512

Keywords: SATA added
Note: See TracTickets for help on using tickets.