Opened 8 years ago

Last modified 5 years ago

#8344 new bug

SSD in Acer W500 isn't recognised

Reported by: lxstoian Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: Acer, W500, SATA Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The ssd in my Acer W500 tablet isn't recognised.

Attachments (4)

listdev.txt (3.5 KB ) - added by lxstoian 8 years ago.
listusb.txt (973 bytes ) - added by lxstoian 8 years ago.
syslog.txt (448.3 KB ) - added by lxstoian 8 years ago.
syslog new.txt (321.0 KB ) - added by lxstoian 8 years ago.

Download all attachments as: .zip

Change History (16)

by lxstoian, 8 years ago

Attachment: listdev.txt added

by lxstoian, 8 years ago

Attachment: listusb.txt added

by lxstoian, 8 years ago

Attachment: syslog.txt added

comment:1 by X512, 8 years ago

Keywords: Acer W500 added

comment:2 by X512, 8 years ago

I successfully installed Haiku on this device one month ago and don't saw any problem with disk or multiboot. Now I uninstall because of #8338. Work with external mouse is unpractical.

comment:3 by lxstoian, 8 years ago

I have tested hrev43824 and still the same problem. Haiku wont see my ssd.

comment:4 by X512, 8 years ago

Strange... I test hrev43826 on Acer W500 and SDD are recognized. Can you show screenshot of DriveSetup?

Last edited 8 years ago by X512 (previous) (diff)

comment:5 by korli, 8 years ago

Component: - GeneralDrivers/Disk
Owner: changed from nobody to marcusoverhagen

The syslog seems to indicate a problem with ATA/AHCI.

comment:6 by marcusoverhagen, 8 years ago

Indeed, but to locate the problem, a syslog with timestamps turned on would be useful.

comment:7 by lxstoian, 8 years ago

Will provide one soon.

by lxstoian, 8 years ago

Attachment: syslog new.txt added

comment:8 by lxstoian, 8 years ago

Here it is.

comment:9 by lxstoian, 7 years ago

This bug is still present in the latest builds both on the Acer w500 and Asus 1215b , but more worryingly I tested Haiku on another AMD APU laptop (E-300) and the bug is also present. It seems Haiku wont see the Hardisk or SSD on any of the new AMD APU devices.

comment:10 by X512, 7 years ago

Sometimes I got no boot partitions error and no SDD in DriveSetup too. It happens randomly.

comment:11 by X512, 5 years ago

This issue can be related to SATA driver. I found option in BIOS that change disk access from SATA to IDE and now internal drive is recognized every boot without problems.

comment:12 by X512, 5 years ago

Keywords: SATA added
Note: See TracTickets for help on using tickets.