Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8346 closed bug (fixed)

Latest nightlies crash upon boot in Virtual Box

Reported by: MadEchidna Owned by: kallisti5
Priority: blocker Milestone: R1/alpha4
Component: User Interface Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8330
Platform: x86

Description

I am running the latest version of Virtual Box on Windows 7 Home Premium 64 bit. I downloaded both haiku-nightly-hrev43762-x86gcc2hybrid-vmware and haiku-nightly-hrev43766-x86gcc2hybrid-cd, and both crash once the tracker and deskbar come up and the notice about ssh keys appears. Mouse becomes inoperative, and if Pulse is running, the CPU meter turns into a solid grey box. I have also confirmed with the a couple of other people on IRC that the same thing is happening to them. I will attach a full log from boot to lockup.

Attachments (2)

haiku crash madechidna.txt (38.2 KB ) - added by MadEchidna 9 years ago.
Full og
APIC off virtualbox.txt (33.9 KB ) - added by MadEchidna 9 years ago.

Download all attachments as: .zip

Change History (10)

by MadEchidna, 9 years ago

Attachment: haiku crash madechidna.txt added

Full og

comment:1 by MadEchidna, 9 years ago

New info, apparently enabling IO APIC fixes this.

comment:2 by kallisti5, 9 years ago

should be fixed in hrev43768, please test (with apic enabled) and confirm

in reply to:  2 comment:3 by MadEchidna, 9 years ago

Replying to kallisti5:

should be fixed in hrev43768, please test (with apic enabled) and confirm

Alright let me build this and I'll test asap

comment:4 by kallisti5, 9 years ago

Milestone: R1R1/alpha4
Owner: changed from stippi to kallisti5
Priority: normalblocker
Status: newassigned

by MadEchidna, 9 years ago

Attachment: APIC off virtualbox.txt added

comment:5 by MadEchidna, 9 years ago

Successfully built and ran hrev43768. Tested booting and running with APIC enabled and disabled. While on previous revision the system locked up at the desktop without APIC, it runs perfectly in both cases now. One small thing I did notice is that when I attempt a clean shutdown without APIC, input_server hangs and must be killed manually. However, the mouse was still functional and I was able to click force close to complete the shutdown process. This does not happen when APIC is enabled.

I have booted and launched GLTeacup and captured the log for your reference. Log is of a boot without APIC enabled.

Nice work kallisti5!

Last edited 9 years ago by MadEchidna (previous) (diff)

comment:6 by taos, 9 years ago

The symptoms seem similiar to those described in #8330. I'll test with hrev43768+, too.

comment:7 by kallisti5, 9 years ago

Resolution: fixed
Status: assignedclosed

comment:8 by kallisti5, 9 years ago

Blocking: 8330 added

(In #8330) as noted in #8346 , give the latest rev a whirl.

Thanks!

Note: See TracTickets for help on using tickets.