Opened 7 years ago

Closed 7 years ago

#8355 closed bug (fixed)

Vision crashes on fresh install

Reported by: Disreali Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: vision crash Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by luroh)

Experienced on a hrev43782-2h nightly.

attaching backtrace.

Attachments (1)

hrev43782-2hn_vision_crash_on_freshly_installed_system.txt (3.7 KB) - added by Disreali 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by Disreali

Summary: Vision crashes on fersh installVision crashes on fresh install

comment:2 Changed 7 years ago by anevilyak

Owner: changed from nobody to anevilyak
Status: newassigned

I don't suppose you'd be able to narrow down what revision that started happening at? I haven't been able to replicate it myself as of yet and I can't think of an obvious recent change that could be a culprit.

comment:3 Changed 7 years ago by pulkomandy

Happens here as well, on a gcc2h fresh install of hrev43781. Was running r436xx before and it worked, if that helps (I guess it doesn't that much...)

comment:4 Changed 7 years ago by luroh

Description: modified (diff)

comment:5 Changed 7 years ago by anevilyak

Confirmed it on a gcc2h build...bisecting now.

comment:6 Changed 7 years ago by anevilyak

Culprit is hrev43773, it breaks binary compatibility with native Haiku apps making use of BControlLook. May simply require a rebuild since that class is still considered experimental.

comment:7 Changed 7 years ago by anevilyak

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev43794.

Note: See TracTickets for help on using tickets.