Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8356 closed bug (invalid)

Folder list selection does not work with the Pe editor

Reported by: Karvjorm Owned by: stippi
Priority: normal Milestone: R1
Component: User Interface Version: R1/alpha3
Keywords: Open menu list selection animation Cc: Karvjorm
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I found the following error when editing some text file on my Desktop. I tried to open another text file in the parent folder of the Desktop folder, but was not able to open list selection menu of the Open menu when using the Pe editor.

Instead of opening list selection menu I got an animation that selected Desktop folder as a work folder for me. The enclosed image files show it.

Attachments (2)

DesktopChange1.png (4.4 KB) - added by Karvjorm 7 years ago.
Desktop folder (Työpöytä in Finnish) in Open menu of the Pe editor
DesktopChange2.png (2.3 KB) - added by Karvjorm 7 years ago.
A large animated image covered the Desktop line of list selection. Desktop folder is now selected.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Karvjorm

Attachment: DesktopChange1.png added

Desktop folder (Työpöytä in Finnish) in Open menu of the Pe editor

Changed 7 years ago by Karvjorm

Attachment: DesktopChange2.png added

A large animated image covered the Desktop line of list selection. Desktop folder is now selected.

comment:1 Changed 7 years ago by axeld

Resolution: invalid
Status: newclosed

First of all, the images that you added seem to come from a standard file panel which means this has nothing to do with Pe in particular.

Second of all, like other UI operating systems, Haiku maintains the illusion that the Desktop folder is the top most folder; everything else is accessible from there.

Please shout if I misunderstood you somehow.

comment:2 in reply to:  1 Changed 7 years ago by Karvjorm

I'm sorry about my mistake about speaking s parent folder. Replying to axeld:

First of all, the images that you added seem to come from a standard file panel which means this has nothing to do with Pe in particular.

Yes, I had understood that (and that is why I filed this here and not at OsDrawer.net, or what it is).

Second of all, like other UI operating systems, Haiku maintains the illusion that the Desktop folder is the top most folder; everything else is accessible from there.

The problem is that everything else is _not_ accessible from there in this case. Not if you first open a text file from the Desktop folder and then try to open another text file from home folder, for example. Surely, you can do it by clicking the home folder at the window below, and then Desktop, a NTFS Volume (in my laptop) and the home folder are visible via that selection component (and it can act as a twitcher). But if you do not do this, there is only a Desktop available. And this is a misleading situation, because the triangle at the right indicates normally that there is a menu to open.

Note: See TracTickets for help on using tickets.