Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8380 closed bug (fixed)

Regression: AR9285 broken in hrev43824

Reported by: tidux Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Network/atheroswifi Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

My netbook's wifi device (/dev/net/atheroswifi/0) can't connect to a network. I attempted connecting to my home network after installing wpa_supplicant. The network was detected, I configured a static IP to avoid the perennial DHCP/WPA2 issues, and I set up the encryption key. I tried pinging the gateway, but I got a "no route to host" error. The output of "route" and "ifconfig" said that there was a route, so I looked at "arp," but there was no entry for the gateway, or for anything but my netbook's own MAC. This is labeled a regression because connecting to that same network with WPA2 and a static IP worked correctly in hrev43728.

Attachments (3)

listdev.out (2.4 KB) - added by tidux 7 years ago.
output of listdev on Eee PC 1005PE
sysinfo.out (2.4 KB) - added by tidux 7 years ago.
output of sysinfo on Eee PC 1005PE
syslog (274.4 KB) - added by tidux 7 years ago.
syslog from Eee PC 1005PE

Download all attachments as: .zip

Change History (22)

comment:1 Changed 7 years ago by tidux

Component: Drivers/Network/atheroswifiDrivers/ACPI
Owner: changed from nobody to tqh

Moving ticket to ACPI.

I encountered a very similar bug on the netbook in question under OpenBSD 5.0, which is currently running with ACPI disabled because of a temp-sensor bug. Rebooting into Knoppix (Debian-based live CD) and connecting to a network seemed to reset something in the wifi NIC; it worked properly after rebooting into OpenBSD.

comment:2 Changed 7 years ago by tqh

Have you confirmed that it is hrev43729 that breaks it?

I don't think it is ACPI related, probably IRQ handling, but I'll take a look.

comment:3 Changed 7 years ago by tqh

Component: Drivers/ACPIDrivers/Network/atheroswifi
Owner: changed from tqh to korli
Status: newassigned

Since the driver got updated in hrev43729 I suspect it is the driver itself.

comment:4 Changed 7 years ago by korli

A syslog would really help: see http://dev.haiku-os.org/wiki/ReportingBugs

comment:5 Changed 7 years ago by tidux

Sorry about the delay, guys. Life got really busy. Here's some files for you.

Changed 7 years ago by tidux

Attachment: listdev.out added

output of listdev on Eee PC 1005PE

Changed 7 years ago by tidux

Attachment: sysinfo.out added

output of sysinfo on Eee PC 1005PE

Changed 7 years ago by tidux

Attachment: syslog added

syslog from Eee PC 1005PE

comment:6 Changed 7 years ago by korli

Would you also have a syslog with hrev43728?

comment:7 Changed 7 years ago by Dilbert2

I have a syslog from my Asus G73sw, running Haiku.

When I boot Haiku from USB drive, I can immediately see all available wireless networks. But it refuses to connect to them. I have installed wpa_supplicant, using the command installoptionalpackage -i wpa_supplicant. I click on my home wifi network, and a dialog box pops up. I fill in the wifi passord (it*s WPA2) and click OK. But the computer DOES NOT connect to it!

My lspci is written in this bug report: https://dev.haiku-os.org/ticket/8227 it's Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I typed tail -F /var/log/syslog in Terminal on the Haiku machine. It keeps writing something new every second. Much of it seems to be about atheroswifi. Here is the output from tail -F /var/log/syslog http://pastebin.com/1Va2jrTL A few lines of text came along when I tried to select my wifi network, but it drowned in spam. That log writes itself really fast.

This is with the latest GCC2 nightly. The situation has been the same for weeks. Older Haiku versions did not find wireless networks. But the latest few weeks, it finds wireless networks, but can*t connect to them.

Syslog: http://pastebin.com/Ad9YVmeG

Last edited 7 years ago by Dilbert2 (previous) (diff)

comment:8 in reply to:  7 Changed 7 years ago by korli

Replying to Dilbert2:

I have a syslog from my Asus G73sw, running Haiku.

There is no attempt at joining a network in this syslog.

comment:9 Changed 7 years ago by Dilbert2

Sorry, I am no programmer, and I can*t understand the output I paste. I*m just following instructions given to me on IRC. The man who gave me the instructions had to go, so I*m trying my best without really knowing what I*m doing :-)

Anyway. I used DD to put the latest nightly GCC2 Haiku on my memory stick. When booting the fresh Haiku for the first time, I installed wpa_supplicant: installoptionalpackage -i wpa_supplinant

Then, I tried to connect to my home wifi network 3 times, by clicking on it in the deskbar. My home network is WPA2 encrypted. Whe connecting to my home network, a dialog box pops up, requesting the password. I type the password, and check the box for storing the configuration. The dialog box disappears, but it does not connect. The next time I try, the password field is blank.

After 3 attempts to connect to my home wifi network, I copied the contents of syslog to Pastebin. Here it is: http://pastebin.com/v5PAwJ3T

I am hoping that this time it contains relevant information.

BTW: Wireless networking works if there is no encryption. But I must reboot the computer to find available networks that were not present at boot. It does not seem to search continously. Networks must be visible at boot.

Last edited 7 years ago by Dilbert2 (previous) (diff)

comment:10 Changed 7 years ago by korli

comment:11 Changed 7 years ago by Dilbert2

YES! That worked for me on my ASUS G73sw laptop. I now have wireless wpa2 internet in Haiku. Great!

But it is not perfect. Quite often an annoying info-box pops up, saying: Network status /dev/net/rt181xx/0 Connection Established

I*m glad it*s working, but it does not need to tell me all the time.

Haven*t had the time to test performance or stability. But at least it works now :-)

And there is no box to check for remembering the wifi preferences, like password. So I must type password for wifi on every boot.

comment:12 Changed 7 years ago by korli

Dilbert2, please file a new bug report for your new problem. Thanks for the feedback.

@tidux, next step: I'll commit the switch to the new wpa_supplicant optional packages and close this bug.

comment:13 Changed 7 years ago by korli

Resolution: fixed
Status: assignedclosed

Updated in hrev43948. Please check and reopen if not working.

comment:14 Changed 7 years ago by paulfxh

I've been following progress here for some time and was glad to see that the problem had been resolved. But, unfortunately, doesn't work for me.

I'm using a EeePC 901 with a ralink2860 wifi card and a wpa2 encrypted network. Since last October, I've been able to get perfect wifi connections in various Haiku nightlies on this machine.

With more recent nightlies, however, wifi no longer connects.

Strangely, when I boot up, a popup tells me that /dev/net/ralink2860/0 has connected. However, no connection has been made.

Right now, I'm using hrev43955 on this machine and, once again, no wifi.

If I quit wpa_supplicant and start it again from a terminal, here's the output I get when I try to connect wifi from the Network Status demo:

Setting scan request: 5 sec 0 usec
Scan SSID - hexdump_ascii(len=10):
     55 50 43 30 30 34 32 30 32 32                     UPC0042022      
Starting AP scan for wildcard SSID
wpa_driver_bsd_set_wpa: enabled=1
wpa_driver_bsd_set_wpa_internal: wpa=3 privacy=1
Received 256 bytes of scan results (1 BSSes)
BSS: Start scan result update 17
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:80:c6:ab:48:69 ssid='' wpa_ie_len=28 rsn_ie_len=0 caps=0x0
   skip - SSID not known
Try to find non-WPA AP
0: 00:80:c6:ab:48:69 ssid='' wpa_ie_len=28 rsn_ie_len=0 caps=0x0
   skip - SSID not known
No suitable network found

This repeats ad infinitum.

Also, the wifi connect dialog box doesn't seem to remember my wpa security password even though I check the "Store this configuration" box as it comes up empty every time.

Even though wpa_supplicant can't seem to find my wifi networks, the Network Status demo picks them up without problem as does "ifconfig /dev/net/ralink2860/0 list".

I've also tried to connect to wifi using the appropriate "ifconfig join" command, but unsurprisingly, this gives the very same result.

Note that the card is fine as it works perfectly in Ubuntu in another partition on the same machine.

comment:15 Changed 7 years ago by paulfxh

OK, have wifi connection (WPA2) using hrev44007 on EeePC 901 (ralink2860). So, everything seems fine now. Thank you. Strangely, although wifi works after a "clean" install, if I only replace the /system directory without initializing the partition I use for Haiku, I can get neither wifi nor an ethernet connection. Wifi also works fine from the hrev44007 as a "live" usb.

comment:16 Changed 7 years ago by diver

Probably it was because of /boot/common/settings/network/wireless_networks config file.

comment:17 in reply to:  16 Changed 7 years ago by paulfxh

Replying to diver:

Probably it was because of /boot/common/settings/network/wireless_networks config file.

I don't understand. This file is not present in hrev44007. However, there is /boot/common/settings/network/interfaces which contains details of my wifi network and connection (but not the password). Are you saying it was mistakenly present in earlier nightlies rather than the interfaces file?

comment:18 Changed 7 years ago by diver

You mentioned that previously you only replaced the /system directory which means that /boot/common/settings/network/ stayed the same. One of config files in that folder could have something which prevented wpa_supplicant/net_server from working properly. Unfortunately we will never know what it was exactly because it's likely you don't have that old folder anymore.

comment:19 in reply to:  18 Changed 7 years ago by paulfxh

Replying to diver:

You mentioned that previously you only replaced the /system directory which means that /boot/common/settings/network/ stayed the same. One of config files in that folder could have something which prevented wpa_supplicant/net_server from working properly. Unfortunately we will never know what it was exactly because it's likely you don't have that old folder anymore.

OK, now I see. Thank you for the explanation. And, no, I do not have the folder you refer to anymore.

Note: See TracTickets for help on using tickets.