Opened 8 years ago

Closed 8 years ago

#8381 closed bug (fixed)

Haiku3D not working

Reported by: Disreali Owned by: kallisti5
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrev43812-2h nightly, launching Haiku3d simple opens a window with a black background. The 3d letter do not appear. Possible related to the new mesa pkg.

Attaching screen capture.

Not sure how to file this as Haiku3d is not in the applications component list.

Attachments (1)

hrev43812-2hn_Haiku3d_ does_not_work.png (84.6 KB ) - added by Disreali 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by anevilyak, 8 years ago

Component: - GeneralKits/OpenGL Kit
Owner: changed from nobody to kallisti5
Status: newassigned

comment:2 by anevilyak, 8 years ago

Added an Applications/Haiku3D component. However, as this one is more likely a mesa regression, assigning to OpenGL kit.

comment:3 by Disreali, 8 years ago

I just did some bisecting and figured out that the Haiku3D app broke somewhere between hrev43745 and hrev43755.

comment:4 by kallisti5, 8 years ago

Thanks for the bisect.

http://cgit.haiku-os.org/haiku/tag/?id=hrev43755 definitely looks to be the cause. Strange that GLTeapot works while Haiku3D doesn't though :\

comment:5 by kallisti5, 8 years ago

Ah. Haiku3D and flurry use non-direct rendering, while GLTeapot uses direct rendering.

Not sure of the cause yet, but that seems to be a common item that could make a big difference.

comment:6 by kallisti5, 8 years ago

Correction: They all *use* direct rendering, however Haiku3d and flurry never try to use it.. while GLTeapot does.

comment:7 by kallisti5, 8 years ago

I have an application side fix... but I pinged the mailing list as I need to know if it really is an application bug, or a bug on my end.

comment:8 by kallisti5, 8 years ago

Testing error.

Last edited 8 years ago by kallisti5 (previous) (diff)

comment:9 by kallisti5, 8 years ago

fixed. As soon as I get this branch merged in i'll post hrev and mark as resolved :)

comment:10 by kallisti5, 8 years ago

Resolution: fixed
Status: assignedclosed

fixed in hrev43847

Note: See TracTickets for help on using tickets.