Opened 7 years ago

Closed 7 years ago

#8387 closed bug (duplicate)

Nightly gcc2hybrid ISO image hrev43840 does not boot in VirtualBox and on real hardware

Reported by: oco Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #8369 Blocking:
Has a Patch: no Platform: All

Description

The debug output end with those errors :

... runtime_loader: /boot/system: Troubles reading ELF header error starting "/bin/sh" error = -2147478782

Here is the download link of this image : http://haiku-files.org/haiku/development/haiku-nightly-hrev43840-x86gcc2hybrid-cd.tar.xz

Change History (7)

comment:1 Changed 7 years ago by bonefish

Component: System/runtime_loader- General
Owner: changed from bonefish to nobody
Version: R1/alpha3R1/Development

comment:2 Changed 7 years ago by lukove

i have this some problem on real hardware when i used CD iso image, in virtualbox too.

comment:3 Changed 7 years ago by oco

After comparing with other images of the same revision, the problem seems related to the symbolic link in /boot/system/bin :

  • in a working image, sh points to bash
  • in the ISO, sh is a directory as it points to "../"

comment:4 Changed 7 years ago by mmadia

Does this occur on ISOs only from haiku-files or even ones that are self-built?

comment:5 Changed 7 years ago by oco

The problem occurs on a self-built gcc2 image too (jam haiku-cd).

comment:6 Changed 7 years ago by oco

The link is ok in generated/tmp/cdsource/system/bin.

comment:7 Changed 7 years ago by anevilyak

Blocked By: 8369 added
Resolution: duplicate
Status: newclosed

Sounds like a possible issue with mkisofs or one of the other cd image generation tools then. In any case, duplicate of #8369.

Note: See TracTickets for help on using tickets.