Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8398 closed bug (fixed)

wpa_supplicant crash in gcc4h hrev43867

Reported by: Hubert Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8268
Has a Patch: no Platform: x86

Description

When I choose network WiFi WPA2 and type the password I have debuger:

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 2880 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/common/lib/libcrypto.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libcrypto.so.1.0.0
Reading symbols from /boot/system/lib/libnetwork.so...done.
Loaded symbols for /boot/system/lib/libnetwork.so
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libstdc++.so...done.
Loaded symbols for /boot/system/lib/libstdc++.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libz.so.1...done.
Loaded symbols for /boot/system/lib/libz.so.1
Reading symbols from /boot/system/lib/libsupc++.so...done.
Loaded symbols for /boot/system/lib/libsupc++.so
Reading symbols from /boot/system/lib/liblocale.so...done.
Loaded symbols for /boot/system/lib/liblocale.so
Reading symbols from /boot/system/lib/libicudata.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicudata.so.48.1.1
Reading symbols from /boot/system/lib/libicui18n.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicui18n.so.48.1.1
Reading symbols from /boot/system/lib/libicuio.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicuio.so.48.1.1
Reading symbols from /boot/system/lib/libicule.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicule.so.48.1.1
Reading symbols from /boot/system/lib/libiculx.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libiculx.so.48.1.1
Reading symbols from /boot/system/lib/libicutu.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicutu.so.48.1.1
Reading symbols from /boot/system/lib/libicuuc.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicuuc.so.48.1.1
Reading symbols from /boot/system/lib/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/common/bin/wpa_supplicant (2880) thread wpa_supplicant (2880)]
0x53e58955 in ?? ()
(gdb) bt
#0  0x53e58955 in ?? ()
#1  0x004a43e5 in BAbstractLayout::AncestorVisibilityChanged ()
   from /boot/system/lib/libbe.so
#2  0x00219664 in wireless_config_dialog ()
#3  0x00222a56 in WPASupplicantApp::MessageReceived ()
#4  0x7ffeec54 in ?? ()
#5  0x7ffeec5c in ?? ()
#6  0x7ffeec58 in ?? ()
#7  0xffffff00 in ?? ()
#8  0x180015a0 in ?? ()
#9  0x00000818 in ?? ()
#10 0x0022adb8 in CSWTCH.79 ()
#11 0x7ffeec58 in ?? ()
#12 0x7ffeec54 in ?? ()
#13 0x0022ada4 in CSWTCH.79 ()
#14 0x0022ada9 in CSWTCH.79 ()
#15 0x7ffeec5c in ?? ()
#16 0x007e942c in ?? () from /boot/system/lib/libroot.so
#17 0x7ffeec3c in ?? ()
#18 0x7ffeec78 in ?? ()
#19 0x007442a5 in spawn_thread () from /boot/system/lib/libroot.so
Previous frame inner to this frame (corrupt stack?)

Change History (3)

comment:1 Changed 7 years ago by diver

Resolution: fixed
Status: newclosed

Probably fixed in hrev43717.

comment:2 Changed 7 years ago by diver

Blocking: 8268 added

(In #8268) Looks like a dupe of #8398.

comment:3 Changed 7 years ago by Hubert

Yep. Now work again. wpa_supplicant working on gcc4h and connected with encrypted WiFi.

Note: See TracTickets for help on using tickets.