Opened 7 years ago

Closed 7 years ago

#8403 closed bug (invalid)

Appearance crashing app_server

Reported by: humdinger Owned by: czeidler
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: decorator Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev43856 gcc2hybrid.

When I change colours in the Appearance preferences and click the "Defaults" button, app_server crashes with this backtrace:

KERN: vm_soft_fault: va 0x0 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0xec, ip 0x59edc7, write 0, user 1, thread 0x183
KERN: vm_page_fault: thread "a:385:x-vnd.Haiku-Appearance" (387) in team "app_server" (78) tried to read address 0xec, ip 0x59edc7 ("libbe.so_seg0ro" +0x214dc7)
KERN: debug_server: Thread 387 entered the debugger: Segment violation
KERN: stack trace, current PC 0x59edc7  ItemAt__C5BListl + 0xf:
KERN:   (0x7096366c)  0x2aae7e  SetTopTap__9Decoratorl + 0x2a
KERN:   (0x7096369c)  0x2a2665  ReloadDecor__6Window + 0x21d
KERN:   (0x709636fc)  0x26848a  ReloadDecor__7DesktopP10DecorAddOn + 0xba
KERN:   (0x7096377c)  0x2a9b7f  SetDecorator__12DecorManagerG7BStringP7Desktop + 0xb3
KERN:   (0x709637cc)  0x27e21a  _DispatchMessage__9ServerApplRQ28BPrivate12LinkReceiver + 0xafe
KERN:   (0x70963ecc)  0x28443f  _MessageLooper__9ServerApp + 0x18f
KERN:   (0x70963f7c)  0x27774c  _message_thread__13MessageLooperPv + 0x28
KERN:   (0x70963fac)  0x8556d3  thread_entry + 0x23

Change History (2)

comment:1 Changed 7 years ago by anevilyak

Owner: changed from axeld to czeidler
Status: newassigned

Looks related to some of the changes that went on in the app_server to accomodate S&T.

comment:2 Changed 7 years ago by humdinger

Resolution: invalid
Status: assignedclosed

I downloaded a new nightly image (hrev43873) and cannot reproduce anymore. Sorry for the noise...

Note: See TracTickets for help on using tickets.