Opened 7 years ago

Closed 4 years ago

#8413 closed bug (fixed)

Debug Server Crash

Reported by: SeanCollins Owned by: bonefish
Priority: normal Milestone: R1
Component: Servers/debug_server Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

this is a odd one, but the debug server crashed

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 35156 caused an exception: Invalid opcode exception
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libdebug.so...done.
Loaded symbols for /boot/system/lib/libdebug.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/liblocale.so...done.
Loaded symbols for /boot/system/lib/liblocale.so
Reading symbols from /boot/system/lib/libicudata.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicudata.so.48.1.1
Reading symbols from /boot/system/lib/libicui18n.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicui18n.so.48.1.1
Reading symbols from /boot/system/lib/libicuio.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicuio.so.48.1.1
Reading symbols from /boot/system/lib/libicule.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicule.so.48.1.1
Reading symbols from /boot/system/lib/libiculx.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libiculx.so.48.1.1
Reading symbols from /boot/system/lib/libicutu.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicutu.so.48.1.1
Reading symbols from /boot/system/lib/libicuuc.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicuuc.so.48.1.1
Reading symbols from /boot/system/lib/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/servers/debug_server (91) thread team 35154 handler (35156)]
0x004d2484 in BPrivate::TextGapBuffer::InsertText ()
   from /boot/system/lib/libbe.so
(gdb) bt
#0  0x004d2484 in BPrivate::TextGapBuffer::InsertText ()
   from /boot/system/lib/libbe.so
#1  0x004ac5f6 in BTextView::InsertText () from /boot/system/lib/libbe.so
#2  0x004a9143 in BTextView::SetText () from /boot/system/lib/libbe.so
#3  0x00419e6b in BAlert::_InitObject () from /boot/system/lib/libbe.so
#4  0x004189d4 in BAlert::BAlert () from /boot/system/lib/libbe.so
#5  0x00205d87 in TeamDebugHandler::_HandleMessage ()
#6  0x00206463 in TeamDebugHandler::_HandlerThread ()
#7  0x0020641b in TeamDebugHandler::_HandlerThreadEntry ()
#8  0x00237153 in thread_entry () from /boot/system/lib/libroot.so
#9  0x70080fec in ?? ()

Change History (2)

comment:1 Changed 4 years ago by SeanCollins

close, we use a new debugger, unable to reproduce.

comment:2 Changed 4 years ago by diver

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.