Opened 7 years ago

Closed 7 months ago

#8418 closed bug (fixed)

Mail incorrectly showing 'x new messages'

Reported by: arfonzo Owned by: czeidler
Priority: normal Milestone: R1
Component: Applications/Mail Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I consistently get Mail/mail_daemon notification icon in the deskbar showing that I have new items, when I don't, hrev43886.

  • A query of all e-mails, and partial e-mails, with attribute Status is "New" shows nothing.
  • The deskbar returns a few mails which all show Status as "Read".
  • I've tried restarting the deskbar and restarting computer.

Change History (8)

comment:1 Changed 7 years ago by anevilyak

Are there by any chance some messages in the trash that you deleted without ever reading?

comment:2 Changed 7 years ago by axeld

Another possible source of error is that the status might not always be set correctly; you should query for the MAIL:read attribute or whatever it's called.

comment:3 Changed 7 years ago by czeidler

Yes try to reopen and close the last mails, sometimes it happens that a mail is marked as read before it is is finished downloaded. Not 100% sure were it exactly goes wrong but also have this problem from time to time. This is a bug in mail...

comment:4 Changed 7 years ago by arfonzo

There are no messages in the trash.

The status, while I agree is not using the "correct" query (as I've constructed my own that is correct, it's the new mail icon that I've got an issue with), there is little that can be done end-user side to change when the new mail flag icon appears?

I've tried to reopen, let them all download, and close the last hundred or so mails, without any success.

comment:5 Changed 7 years ago by arfonzo

As an update, I've been able to reset the notification icon. It's not a solution to this problem, but at least fixes the icon showing new mail, when it shouldn't.

  • Quit the mailer daemon if it's running, or anything that might read/write to ~/mail.
  • Delete all mails from your mail folder. I am not sure why, but completely deleting the mail folder did not do happy things on my system. You'll probably want to mirror your entire mail folder beforehand, and zip/tarball it, for example (so they don't show in queries).
  • Check the icon in the deskbar, it should now show no new mails.
  • Re-start the mailer daemon, and re-fetch all your mail.
  • Please take extra care to read czeidler's tip. Following this rule (open a mail, and let it finish downloading, before closing it), I have managed to keep that notification synced for 2 days now.

If you only delete your e-mail files, you'll keep your queries, etc. as-is. Hope this helps someone, until the issue is resolved.

comment:6 Changed 7 years ago by arfonzo

Er, you'll want to restart the mailer daemon *before* you look for the icon showing no new mails. Oops. :)

comment:7 Changed 7 years ago by arfonzo

I don't seem to have this problem with hrev43762. I have completely deselected the option to partially download messages.

comment:8 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.