Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8419 closed bug (duplicate)

PANIC: ASSERT FAILED (/Buildbot/nightly-uploader/workdir/haiku/src/system/kernel/fs/vfs.cpp:950): vnode->ref_count ==0 && vnode->IsBusy(); vnode: 0xd7ea1828

Reported by: arfonzo Owned by: nobody
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc: SeanCollins
Blocked By: #3159 Blocking:
Has a Patch: no Platform: All

Description

I am seeing this panic quite often, hrev43886. Attached are two screenshots of the panic screen.

An example scenario:

  • I've tried to clone from git the haiku source following the building guide, 4-5 times now. Each time I get a panic to KDL in git at the same point.
  • I did a git clone, on my linux machine. Then I tar'd that up, and wget'd it onto haiku and, same type of panic during un-tar.
  • Diver has suggested: there is a bug hiding in bfs/block_cache/some heavy operation triggers it.
  • That is consistent with what i'm seeing, although, it seems to be more specific than heavy usage, every single time KDL was brought up was at the same point/file in the git cloning process.

Attachments (2)

haiku_kdl_git.png (410.6 KB ) - added by arfonzo 8 years ago.
haiku_unzip_kdl.png (710.4 KB ) - added by arfonzo 8 years ago.

Download all attachments as: .zip

Change History (8)

by arfonzo, 8 years ago

Attachment: haiku_kdl_git.png added

by arfonzo, 8 years ago

Attachment: haiku_unzip_kdl.png added

comment:1 by SeanCollins, 8 years ago

look in boot/common/var/log/syslog.I'd like to compared yours to mine, becuase I have about 50 screen shots I have collected this week that are similar, even though they effect different files.How do I cc myself to the ticket ? or could someone please CC me ? thanks.

Last edited 8 years ago by SeanCollins (previous) (diff)

comment:3 by arfonzo, 8 years ago

I was able to avoid this panic during my git clone scenario above, by reducing the amount of RAM available to the machine from 4096 down to 512. Not sure if this may be relevant.

comment:4 by SeanCollins, 8 years ago

Thats a bit odd ? reducing the system ram, removed the error ? strange

comment:5 by anevilyak, 8 years ago

Blocked By: 3159 added
Component: File SystemsFile Systems/BFS
Resolution: duplicate
Status: newclosed

Duplicate of #3159.

comment:6 by tqh, 8 years ago

Sounds like also running a comprehensive memcheck on the computer would be good just to eliminate bad ram suspicion.

Note: See TracTickets for help on using tickets.