Opened 8 years ago

Closed 10 months ago

Last modified 10 months ago

#8455 closed enhancement (fixed)

ich9m-e/m sata ahci driver

Reported by: pragmavalue Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Kernel Panic on my system (notebook), i need a ich9m-e/m sata ahci driver

Attachments (2)

kernel_panic.jpg (144.8 KB ) - added by diver 8 years ago.
SYSLOG00.TXT (48.7 KB ) - added by pragmavalue 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 by diver, 8 years ago

Component: - GeneralDrivers/Disk
Owner: changed from nobody to marcusoverhagen

Have you tried it with nightly? Please include your listdev/lspci and also an image of a kernel panic.

comment:2 by pragmavalue, 8 years ago

Yes, i tried a liveCD R1/A3 and nightly 43966 and their is a that same error

I don't have any F32 partitions or Serial device to include listdev/lspci log sorry

Last edited 8 years ago by diver (previous) (diff)

by diver, 8 years ago

Attachment: kernel_panic.jpg added

comment:3 by diver, 8 years ago

If you have an usb stick you can format it with fat32 and then save your syslog from the bootloader.
Could you also attach "lspci -nn" output from linux&

comment:4 by diver, 7 years ago

Blocking: 7665 added

by pragmavalue, 7 years ago

Attachment: SYSLOG00.TXT added

comment:5 by pragmavalue, 7 years ago

Hi

I made new F32 Partition and wrote some log file, I try with newest nightly 44597 and still dont work.

comment:6 by marcusoverhagen, 7 years ago

This should be fixed with hrev44627. The one you tested is too old.

comment:7 by marcusoverhagen, 7 years ago

hrev44597 only scans sata ports 0,1 and 4, while hrev44627 will also scan port 5.

On port 0 it finds "ADATA SSD S510 120GB", port 1 and 4 are empty.

Is an additional HDD in the sytem that you try to boot haiku from?

Last edited 7 years ago by marcusoverhagen (previous) (diff)

comment:8 by pragmavalue, 7 years ago

No, i have 1 hdd. I think a system do not see a DVD-RW and that fault is show.

comment:9 by waddlesplash, 16 months ago

Keywords: boot-failure added; ich9m-e/m removed

comment:10 by waddlesplash, 16 months ago

Blocking: 7665 removed

comment:11 by waddlesplash, 10 months ago

Still an issue?

comment:12 by waddlesplash, 10 months ago

Resolution: fixed
Status: newclosed

Rereading history, it seems this was probably fixed with hrev44627 but the reporter never tested that. Assuming fixed.

comment:13 by pragmavalue, 10 months ago

hi, sorry but this notebook is burn up and i'am don't use them.

Note: See TracTickets for help on using tickets.