Opened 7 years ago

Closed 7 months ago

Last modified 7 months ago

#8455 closed enhancement (fixed)

ich9m-e/m sata ahci driver

Reported by: pragmavalue Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Kernel Panic on my system (notebook), i need a ich9m-e/m sata ahci driver

Attachments (2)

kernel_panic.jpg (144.8 KB) - added by diver 7 years ago.
SYSLOG00.TXT (48.7 KB) - added by pragmavalue 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by diver

Component: - GeneralDrivers/Disk
Owner: changed from nobody to marcusoverhagen

Have you tried it with nightly? Please include your listdev/lspci and also an image of a kernel panic.

comment:2 Changed 7 years ago by pragmavalue

Yes, i tried a liveCD R1/A3 and nightly 43966 and their is a that same error

I don't have any F32 partitions or Serial device to include listdev/lspci log sorry

Last edited 7 years ago by diver (previous) (diff)

Changed 7 years ago by diver

Attachment: kernel_panic.jpg added

comment:3 Changed 7 years ago by diver

If you have an usb stick you can format it with fat32 and then save your syslog from the bootloader.
Could you also attach "lspci -nn" output from linux&

comment:4 Changed 7 years ago by diver

Blocking: 7665 added

Changed 7 years ago by pragmavalue

Attachment: SYSLOG00.TXT added

comment:5 Changed 7 years ago by pragmavalue

Hi

I made new F32 Partition and wrote some log file, I try with newest nightly 44597 and still dont work.

comment:6 Changed 7 years ago by marcusoverhagen

This should be fixed with hrev44627. The one you tested is too old.

comment:7 Changed 7 years ago by marcusoverhagen

hrev44597 only scans sata ports 0,1 and 4, while hrev44627 will also scan port 5.

On port 0 it finds "ADATA SSD S510 120GB", port 1 and 4 are empty.

Is an additional HDD in the sytem that you try to boot haiku from?

Last edited 7 years ago by marcusoverhagen (previous) (diff)

comment:8 Changed 7 years ago by pragmavalue

No, i have 1 hdd. I think a system do not see a DVD-RW and that fault is show.

comment:9 Changed 12 months ago by waddlesplash

Keywords: boot-failure added; ich9m-e/m removed

comment:10 Changed 12 months ago by waddlesplash

Blocking: 7665 removed

comment:11 Changed 7 months ago by waddlesplash

Still an issue?

comment:12 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Rereading history, it seems this was probably fixed with hrev44627 but the reporter never tested that. Assuming fixed.

comment:13 Changed 7 months ago by pragmavalue

hi, sorry but this notebook is burn up and i'am don't use them.

Note: See TracTickets for help on using tickets.