Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8456 closed bug (duplicate)

AMD SB850 support

Reported by: pragmavalue Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: AMD SB850 Cc:
Blocked By: #8085 Blocking:
Has a Patch: no Platform: All

Description

my mainboard is Gigabyte GA-870A-UD3

Don't works: PCIDE - AMD SB850 and JMB362 SATA USB

Haiku work only on VirtualBOx

Attachments (4)

syslog (444.0 KB ) - added by SeanCollins 8 years ago.
USB.jpg (247.5 KB ) - added by pragmavalue 8 years ago.
USB Crash
settings.jpg (145.8 KB ) - added by pragmavalue 8 years ago.
This settings help to boot system
syslog.2 (425.7 KB ) - added by pragmavalue 7 years ago.
after patch

Download all attachments as: .zip

Change History (12)

by SeanCollins, 8 years ago

Attachment: syslog added

comment:1 by SeanCollins, 8 years ago

Can you take some pictures of your bios settings ? I attached a log of a 8xx series amd chipset, thats been running fine for a very long time. Also can you enable on screen debugging, I might be able to help you to get that board to boot. Its very likly a ahci configuration issue.

comment:2 by diver, 8 years ago

At which point does it crash/hang? Try to play with different bootloader options. You have given very little information to go on.

by pragmavalue, 8 years ago

Attachment: USB.jpg added

USB Crash

by pragmavalue, 8 years ago

Attachment: settings.jpg added

This settings help to boot system

comment:3 by diver, 8 years ago

Blocked By: 8085 added
Component: - GeneralSystem/Kernel
Resolution: duplicate
Status: newclosed
Type: enhancementbug

Most likely a dupe of #8085.

comment:4 by SeanCollins, 8 years ago

in the bios, disable the legacy ide controller, make sure the ahci/sata controllers are not set to raid but to ahci. I'd bet that will get it to boot.

Last edited 8 years ago by luroh (previous) (diff)

comment:5 by pragmavalue, 8 years ago

when i enable, in bios, this option my computer don't see any hard divers :/ and windows 7 don't start

comment:6 by SeanCollins, 8 years ago

http://support.microsoft.com/kb/922976

that will fix you non boot with windows7

it sounds like you when you setup the pc the bios was set to legacy ide mode, the haiku ahci driver will choke as will a few other features giving you a no boot situation. After you follow the instructions in that link, go into the bios setting and set the bios up so the hdd's are in ahci mode only. That should get haiku to boot.

in reply to:  6 comment:7 by HAL, 8 years ago

Replying to SeanCollins:

http://support.microsoft.com/kb/922976

that will fix you non boot with windows7

it sounds like you when you setup the pc the bios was set to legacy ide mode, the haiku ahci driver will choke as will a few other features giving you a no boot situation. After you follow the instructions in that link, go into the bios setting and set the bios up so the hdd's are in ahci mode only. That should get haiku to boot.

I enabled AHCI in the BIOS now Haiku wont boot. It would not boot before in IDE mode if the C1E was enabled in the BIOS but on disabling that it would boot. By the way that link did also fix my Windows 7 partition that would not boot in AHCI SATA mode. Is there another bug already about Haiku not booting with AHCI enabled? I might have to post one.

comment:8 by pragmavalue, 7 years ago

Yes, well done on x86-gcc4hybrid 44063 haiku boot up is ok (no safemode, only normal boot). Maybe that patch help us 0001-x86-AMD-C1E-with-no-ARAT-Always-Running-APIC-Timer-i.patch.

Thanks to all

by pragmavalue, 7 years ago

Attachment: syslog.2 added

after patch

Note: See TracTickets for help on using tickets.