Opened 7 years ago

Closed 7 years ago

#8462 closed bug (duplicate)

Setting a locale other than EN SegFaults

Reported by: jahaiku Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: #8452 Blocking:
Has a Patch: no Platform: All

Description

gcc4 build of hrev43968.
If I set a locale to e.g. German every App is crashing. With some tricks I got a bt.

Attachments (2)

err1.png (64.1 KB) - added by jahaiku 7 years ago.
err2.png (72.3 KB) - added by jahaiku 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by jahaiku

Attachment: err1.png added

Changed 7 years ago by jahaiku

Attachment: err2.png added

comment:1 Changed 7 years ago by jahaiku

Summary: Setting a local other than EN SegFaultsSetting a locale other than EN SegFaults

comment:2 Changed 7 years ago by diver

Version: R1/alpha3R1/Development

Looks like a dupe of #8452.

comment:3 Changed 7 years ago by jahaiku

Looks like this change is causing this:
http://cgit.haiku-os.org/haiku/diff/src/kits/interface/Menu.cpp?id=60f75e901ce3063c63441ac644dd0e55a17d5d09
Is gSystemCatalog NULL - where is it set?

comment:4 Changed 7 years ago by mt

Hi, Adding English as fallback language in locale preflet may help you. (It is temporary solution.)

comment:5 Changed 7 years ago by diver

Blocked By: 8452 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.