Opened 7 years ago

Closed 7 years ago

#8452 closed bug (fixed)

Applications crashes after locale change

Reported by: mt Owned by: zooey
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8462
Has a Patch: no Platform: x86

Description

After I changed locale default to Japanese and restart Tracker from locale prefret options tab, then applications (Tracker, Deskbar...) crashes.
revision: hrev43955, gcc4/gcc2 hybrid.

Attachments (2)

syslog.txt (141.8 KB) - added by mt 7 years ago.
syslog
backgrounds.png (18.2 KB) - added by mt 7 years ago.
Backgrounds preflet, color labels are not translated

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by mt

Attachment: syslog.txt added

syslog

comment:1 Changed 7 years ago by diver

Can't reproduce it here with hrev43955 gcc4 hybrid.

comment:2 Changed 7 years ago by diver

On a side note it seems that you have "Translate applications and folder names" enabled, I suggest to disable it for now, see #8275.

comment:3 Changed 7 years ago by anevilyak

Component: Kits/Interface KitKits/Locale Kit
Owner: changed from axeld to pulkomandy

comment:4 Changed 7 years ago by mt

Hi, I found temporary solution: When setting preferred language in locale preflet, add English as fallback language. Then apps do not crash.

comment:5 Changed 7 years ago by diver

Blocking: 8462 added

comment:6 Changed 7 years ago by diver

Owner: changed from pulkomandy to zooey
Status: newassigned

comment:7 Changed 7 years ago by zooey

Status: assignedin-progress

comment:8 Changed 7 years ago by zooey

Resolution: fixed
Status: in-progressclosed

Should be fixed in hrev44024.

comment:9 Changed 7 years ago by mt

Thanks zooey, I tested hrev44025, applications don't crash, but it seems applications can't load localkit catalogs (ex. BColorControl color label).

Changed 7 years ago by mt

Attachment: backgrounds.png added

Backgrounds preflet, color labels are not translated

comment:10 in reply to:  9 Changed 7 years ago by mt

Replying to mt:

but it seems applications can't load localkit catalogs (ex. BColorControl color label).

It seems Jamfile / build system problem (boot/system/data/locale/catalogs/x-vnd.Haiku-libbe/ folder contains no translated catalogs).

comment:11 Changed 7 years ago by zooey

Resolution: fixed
Status: closedreopened

Right, I don't get any catalogs for libbe either, I didn't notice before because I was using 'update-all'. Thanks for the hint!

Reopening ...

comment:12 Changed 7 years ago by zooey

Resolution: fixed
Status: reopenedclosed

Should be fixed for real in hrev44033.

Note: See TracTickets for help on using tickets.