Opened 8 years ago

Last modified 18 months ago

#8485 new bug

Radeon HD 6770 - driver now works, but second display remains black.

Reported by: Bouncer Owned by: kallisti5
Priority: normal Milestone:
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: #8612, #8626, #8826 Blocking:
Has a Patch: no Platform: x86

Description (last modified by diver)

I have a Radeon HD 6770 card.
And two high-res (1920x1200) monitors attached.
#1 is Displayport.
#2 is DVI.
The build I tested with is Haiku Nightly GCC4-Hybrid (hrev44063).

First - I am happy that the Radeon drivers finally work with the HD6770 card.
However - it only displays on the DVI connected monitor. The DisplayPort monitor remains Black. To be clear - when I have both monitors connected, only the DVI monitor lights up.

With older Radeon Cards (and even when using the VESA drivers) - both monitors would light up with the same image. This is the default behavior I have seen with other OS's as well.

I know that Haiku does not yet support multiple displays, but the behavior I have seen previously in haiku, and my 'reasonable expectation', is that all monitors should light up.

Attachments (1)

syslog.GCC4Hyb.44063 (209.6 KB ) - added by Bouncer 8 years ago.

Download all attachments as: .zip

Change History (7)

by Bouncer, 8 years ago

Attachment: syslog.GCC4Hyb.44063 added

comment:1 by diver, 8 years ago

Component: Audio & VideoDrivers/Graphics/radeon_hd
Description: modified (diff)
Owner: changed from nobody to kallisti5

comment:2 by kallisti5, 8 years ago

Blocked By: 8626 added

comment:3 by Bouncer, 7 years ago

Blocked By: 8826 added

comment:4 by kallisti5, 7 years ago

on this issue, the bigger issue is the lack of functioning displayport support. DisplayPort support is in progress... hopefully will be done before R1 betas

comment:5 by kallisti5, 7 years ago

Blocked By: 8612 added

comment:6 by waddlesplash, 18 months ago

Milestone: R1
Note: See TracTickets for help on using tickets.