Opened 7 years ago

Closed 2 years ago

#8532 closed bug (fixed)

fs_[f]open_attr() ignores O_EXCL

Reported by: axeld Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you use O_CREAT, and O_EXCL with fs_open_attr(), the call will succeed even if the attribute already exists.

I haven't investigated if the problem is in the VFS or BFS.

Change History (2)

comment:1 Changed 7 years ago by bonefish

Component: System/KernelFile Systems/BFS
Version: R1/alpha3R1/Development

The VFS only needs to handle O_CREAT, which AFAICT it does.

comment:2 Changed 2 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev50874. I waited five years, but no one wanted to fix it.

Note: See TracTickets for help on using tickets.