Opened 7 years ago

Closed 4 months ago

Last modified 4 months ago

#8533 closed bug (not reproducible)

S-ATA and AHCI boot problem

Reported by: Morbid Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

My Pc is setup in plain AHCI-Mode. 2 HD-drives, 1 DVD-Burner and 1 DVD-ROM all attached to S-ATA. Burned hrev44108 x86 gcc2hybrid-anyboot to a CDRW and trying to boot the machine. The PC boots up from DVD-Device and automatically the Boot-Manager of Haiku starts. No DVD or HD will detect. It's not possible to scan for Boot-Devices and only the Reboot-Option is available. Booting up the PC with USB-Stick and mount the two HD-Devices (both Ntfs) works. Tried Haiku R1 alpha 3 and other Hrev's, too. Than i changed the Option S-ATA as IDE in the Bios with the same effect.

MainBoard: ASUS 939A785GMH/128M

CPU: AMD Athlon 64 3200+

RAM: 4 GByte

HD's S-ATA: Samsung HD103SJ ATA and WDC WD15EARS-00Z5B1 ATA

DVD's S-ATA: HL-DT-ST DVDRAM GH22LS50 ATA (DVD-Burner) and Optiarc DVD-ROM DDU1681S ATA

Chipset's: Northbridge AMD 785G and Southbridge AMD SB710

S-ATA: Controller detected by Windows - Standart AHCI 1.0 Serial ATA (no Problems under Windows)

Attachments (4)

syslog_firstboot_USB.txt (129.9 KB) - added by Morbid 6 years ago.
boot_with_USB.png (79.6 KB) - added by Morbid 6 years ago.
mounted_HaikuCD_2.png (157.7 KB) - added by Morbid 6 years ago.
syslog_aftermount_HaikuCD (266.4 KB) - added by Morbid 6 years ago.

Download all attachments as: .zip

Change History (26)

comment:1 Changed 7 years ago by diver

Version: R1/alpha3R1/Development

comment:2 Changed 6 years ago by diver

Blocking: 7665 added

comment:3 Changed 6 years ago by anevilyak

Blocking: 8953 added

(In #8953) Erm, misread that one. Looks possibly related to #8533 though.

comment:4 Changed 6 years ago by tqh

Someone reported it working when disabling HPET in BIOS. Might be related to the problems mentioned here perhaps? http://en.wikipedia.org/wiki/High_Precision_Event_Timer

HPET is a continuously running timer that counts upward, not a one-shot device that counts down to zero, causes one interrupt and then stops. Since HPET compares the actual timer value and the programmed target value on equality rather than "greater or equal", interrupts can be missed if the target time has already passed when the comparator value is written into the chip's register. In the presence of non-maskable interrupts (such as System Management Interrupts) that do not have a hard upper bound on their execution time, this race condition requires time-consuming re-checks of the timer after setup and is hard to avoid completely. The difficulties are exacerbated if the comparator value is not synchronized with the timer immediately, but delayed by one or two ticks, as some chipsets do.

comment:5 Changed 6 years ago by Morbid

Locate the ACPI HPET Table under Advanced Settings in BIOS. It was Disabled but i tried it again with a version of Haiku after hrev44108. Boot up once with HPET disabled and once enabled. Both with the same effect as i wrote above. Thanks for trying to help.

comment:6 Changed 6 years ago by Morbid

The Bios is by American Megatrends V02.67! I don't know if it is important?

comment:7 Changed 6 years ago by marcusoverhagen

does it work now? a fix to probably related sata problem has been applied to the latest alpha

comment:8 Changed 6 years ago by Morbid

Sorry! Didn't work! Burned Hrev1alpha4-44601 to a DVD-RW and trying to boot. Same result as above!

comment:9 Changed 6 years ago by korli

Blocking: 8953 removed

comment:10 Changed 6 years ago by korli

Since your boot doesn't get past the boot manager, it's probably not a AHCI driver problem. Already tried the ISO format?

comment:11 Changed 6 years ago by Morbid

That was in my brain too after Marcus fix didn't work. So I tried anyboot and ISO image! Tried the hrev1alpha4-44601 that i've burned to DVD-RW on an old PC too, where i have only IDE-Ports, and it boot up.

Last edited 6 years ago by Morbid (previous) (diff)

comment:12 Changed 6 years ago by Morbid

Or could it be a Problem with the CPU? In my old PC there is a Pentium III with 1.11 Ghz installed.

comment:13 Changed 6 years ago by Morbid

On AMD-PC no symbols are shown. Jumps directly into the Boot-Manager. The first Boot-Icon should be the Atom, right? As i read in my Zeta-Book this Symbol means delivery from Boot-Manager to the Kernel! Init of HD is Symbol Number 5. I expect Korli was right and it's not a driver problem, because when i boot via USB-Stick the System boot up and i have access to my HD's and CD-Drives on S-ATA.

Last edited 6 years ago by Morbid (previous) (diff)

Changed 6 years ago by Morbid

Attachment: syslog_firstboot_USB.txt added

Changed 6 years ago by Morbid

Attachment: boot_with_USB.png added

comment:14 Changed 6 years ago by marcusoverhagen

The syslog shows the ahci driver detects and publishes 4 sata devices. Nothing wrong here.

Please try booting from usb and try to mount Haiku CD.

1235 KERN: device 0: /dev/disk/scsi/2/0/0/raw 1239 KERN: size: 1000204886016 (953869.71 MB)

1288 KERN: device 1: /dev/disk/scsi/2/1/0/raw 1292 KERN: size: 1500301910016 (1430799.398 MB)

1324 KERN: device 2: /dev/disk/scsi/2/2/0/raw 1325 KERN: media status: No media present

1327 KERN: device 3: /dev/disk/scsi/2/3/0/raw 1328 KERN: media status: No media present

Changed 6 years ago by Morbid

Attachment: mounted_HaikuCD_2.png added

Changed 6 years ago by Morbid

Attachment: syslog_aftermount_HaikuCD added

comment:15 Changed 6 years ago by marcusoverhagen

Component: Drivers/DiskSystem/Kernel
Owner: changed from marcusoverhagen to axeld

I'm sorry but this doesn't appear to be a problem of the AHCI driver. The AHCI driver seems to detect all HDD and CD-ROM properly.

If possible, please attach a syslog showing a failed boot from CD-ROM, I hope that perhaps someone else can investigate this further.

comment:16 Changed 5 years ago by Morbid

Equal Board with just another CPU (AMD Athlon 64 x 2) and hrev47147. Same as written above! Trying to boot via USB. Halt in Haiku-Bootscreen at Symbol Nr. 4.

Last edited 5 years ago by Morbid (previous) (diff)

comment:17 Changed 20 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:21 Changed 5 months ago by cocobean

@Morbid - is this ticket still revelant on your hardware? Can you retest with recent nightly images?

comment:22 Changed 4 months ago by waddlesplash

Keywords: boot-failure added

comment:23 Changed 4 months ago by Morbid

Hardware no more in use. Ticket could be closed for me. Thanks.

comment:24 Changed 4 months ago by waddlesplash

Resolution: not reproducible
Status: assignedclosed

comment:25 Changed 4 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.