Opened 13 years ago

Closed 13 years ago

#854 closed bug (fixed)

TextView chokes on "\n"

Reported by: johndrinkwater Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

A recent change to TextView has broken line endings.

How to reproduce: load AboutHaiku, looks at the credits view or load StyledEdit, enter a few lines of text, and save.

hrev18847

(Reported on behalf of Stargater)

Change History (5)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by jackburton

Owner: changed from axeld to jackburton
Status: newassigned

comment:3 Changed 13 years ago by jackburton

Milestone: R1

comment:4 Changed 13 years ago by jackburton

Found the problem: http://svn.berlios.de/viewcvs/haiku/haiku/trunk/src/kits/interface/TextView.cpp?rev=18837&r1=18836&r2=18837

unfortunately BView::DrawString() chokes on newlines, I removed the lenght parameter, but looks like I have to put it back.

comment:5 in reply to:  4 Changed 13 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Replying to jackburton:

Fixed in hrev18874

Note: See TracTickets for help on using tickets.