Opened 7 years ago

Closed 6 years ago

Last modified 11 months ago

#8575 closed bug (invalid)

No Boot: reset after "Loading system"

Reported by: phonon Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: Cc: phonon
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Haiku version: haiku-nightly-hrev44146-x86gcc2hybrid-anyboot the image was copied with dd to a usb stick on a Linux system. The system contains a quad-core AMD processor (more details of the hardware are attached, the file was created with sudo lshw -html >> system_info.html on Linux). During boot, the message "Loading system" was displayed, then the machine rebooted. The same bug was reproduced with some older nightly builds, also gcc 4 builds. On a system with intel cpu, the same usb stick was loading and running the whole system without problems.

Attachments (1)

system_info.html (92.5 KB) - added by phonon 7 years ago.
system hardware information

Download all attachments as: .zip

Change History (21)

Changed 7 years ago by phonon

Attachment: system_info.html added

system hardware information

comment:1 Changed 7 years ago by diver

Could you check if the same thing happens when you boot from cd and when you dd it to a hard drive partition and boot from it?

comment:2 Changed 7 years ago by phonon

The reboot also appers with dd to a hard drive and with a cd (created with the respective .iso file). The cd-version has a slight variation though: instead of the message "Loading system", some dots "......." appear one after the other before reboot.

comment:3 Changed 7 years ago by diver

Could you try with raw image instead of anyboot?

comment:4 Changed 7 years ago by phonon

Similar results with haiku-nightly-hrev44149-x86gcc2hybrid-raw : the Computer reboots shortly after power on, but with the raw version, no message (such as "Loading system") is displayed. Tested with hdd and usb.

comment:5 Changed 7 years ago by diver

Loading system seems to come from this file: http://cgit.haiku-os.org/haiku/tree/src/bin/writembr/mbr.S#n364 Do you have a serial port in this computer?

comment:6 Changed 7 years ago by phonon

Yes, there is a com port. Can you make a suggestion what i can do with it?

comment:7 Changed 7 years ago by diver

You can enable serial debug output in the bootloader. You need to connect another computer serially via null modem cable and start a serial terminal (minicom or Putty in windows) there with a 115200, 8n1 connection. While booting up Haiku hold SHIFT to enter the boot options and activate "Enable serial debug output" from the debug options. IIRC it's even enabled by default in the nightlies. Continue booting and now capture Haiku's syslog with the other machine.

comment:8 Changed 7 years ago by phonon

When I hold down the SHIFT key during boot, I have the same problem: the PC resets before i can enter the boot options. This was tried with a usb and with a PS2 Keyboard. On another machine, entering into boot options with SHIFT (with the same usb-stick) was possible.

comment:9 Changed 7 years ago by diver

I think that you don't need to enter the bootloader as serial debug output should be enabled by default in nightlies.

Last edited 7 years ago by diver (previous) (diff)

comment:10 Changed 7 years ago by phonon

Just ordered some missing parts... next step will take some time.

comment:11 Changed 7 years ago by phonon

Last edited 7 years ago by phonon (previous) (diff)

comment:12 Changed 7 years ago by phonon

Cc: phonon added

comment:13 Changed 7 years ago by phonon

There seems to be no output from the serial connection during haiku boot. The serial connection was tested before and after boot with Linux and the PC on the other end received data. When booting haiku with a virtual machine, there is output via the (virtual) serial connection though. Also, I changed the file haiku/tree/src/system/boot/loader/menu.cpp, adding

item->SetEnabled(true);
item->SetMarked(true);

at the appropriate location and created a haiku-nightly-anyboot.image . Still, there was no serial output visible. In my BIOS settings, there are four possible assignments for IRQ and serial port address (3F8/IRQ4 ; 2F8/IRQ3 ; 3E8/IRQ4 ; 2E8/IRQ3). On Linux, this setting has the effect of switching between /dev/ttyS0, /dev/ttyS2 etc.

comment:14 Changed 7 years ago by phonon

Same results with Alpha 4 and hrev44584: reset before boot and no serial messages

comment:15 Changed 6 years ago by phonon

Following some discussion at http://www.freelists.org/post/haiku/how-can-I-get-HAIKU-running-on-my-PC , the problem was partly solved: I checked again my BIOS settings, and in Integrated peripherals -> On-Chip ATA Devices ->RAID Mode I changed from RAID to IDE (as far as I know it's fakeraid, used it for mirroring). Then, HAIKU bootet flawlessly! Is there a chance to get it running even with RAID? Thanks for the help so far.

comment:16 Changed 6 years ago by scottmc

Resolution: fixed
Status: newclosed

Closing this as fixing. Feel free to open an enhancement ticket for the RAID issue.

comment:17 Changed 6 years ago by umccullough

Hmm... fixed is probably wrong in this context (maybe Invalid?)

In any case, it should work in AHCI mode if your BIOS also supports that feature.

IMO, 'fakeraid' mode should work out of the box as long as none of the drives have been configured as RAID - at least a lot of BIOS come with RAID mode enabled by default these days.

comment:18 Changed 6 years ago by axeld

Resolution: fixed
Status: closedreopened

comment:19 Changed 6 years ago by axeld

Resolution: invalid
Status: reopenedclosed

Assuming a BIOS problem without further information.

comment:20 Changed 11 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.