Opened 7 years ago

Closed 5 years ago

#8591 closed bug (invalid)

Haiku crashes with bad mount command

Reported by: waddlesplash Owned by: nobody
Priority: normal Milestone: R1
Component: File Systems Version: R1/Development
Keywords: Cc: ajcsweb@…, scgtrp
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a Haiku GCC4 Hybrid nightly in a VirtualBox (4.1.14) installation. I have yet to get the shared folders working. However, I accidentally typed the following command in a terminal:

mount -t vboxsf Desktop/VBox

Desktop/VBox (folder) does exist. As you can see, there is no drive specified, but there are two spaces between the vboxsf and the Desktop/VBox.

The result is that Haiku crashes (yes, this is reproducible). Attached is a screenshot of the crash with the stack trace.

Attachments (1)

HaikuCrash.png (39.1 KB ) - added by waddlesplash 7 years ago.
Screenshot of crash

Download all attachments as: .zip

Change History (6)

by waddlesplash, 7 years ago

Attachment: HaikuCrash.png added

Screenshot of crash

comment:1 by waddlesplash, 7 years ago

Cc: ajcsweb@… added

comment:2 by waddlesplash, 7 years ago

I meant to say:

mount -t vboxsf  Desktop/VBox

Which is different (has 2 spaces instead of one). You can see this in the screenshot.

comment:3 by diver, 7 years ago

Cc: scgtrp added

Sounds like a bug in vboxsf.

comment:4 by axeld, 7 years ago

An extra space would be removed by shell parsing, so this should not have any effect on the outcome. Either way, the bug seems to be in vboxsf.

comment:5 by waddlesplash, 5 years ago

Resolution: invalid
Status: newclosed

Very well, closing as invalid as vboxsf is not tracked here.

Note: See TracTickets for help on using tickets.