Opened 7 years ago

Closed 11 months ago

#8619 closed bug (fixed)

mail_daemon always crash.

Reported by: Giova84 Owned by: czeidler
Priority: normal Milestone: R1
Component: Servers/mail_daemon Version: R1/Development
Keywords: mail daemon crash on shutdown or when change preferences Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When i shutdown Haiku or when i try to change email preferences i always get an error related to mail_daemon. I've tried to reinstall Haiku four times, but mail_daemon still crashing. No issues when i receive emails.

hrev44221

Attachments (1)

error.png (7.1 KB ) - added by Giova84 7 years ago.

Download all attachments as: .zip

Change History (15)

by Giova84, 7 years ago

Attachment: error.png added

comment:1 by Giova84, 7 years ago

I have to correct this ticket: now mail_daemon also crash when new emails are received. Is strange, because this morning this didn't happened.

comment:2 by Giova84, 7 years ago

In syslog i found some errors related to mail_daemon and to BeMAIL. I read about missing libs: on my system some of these libs are really absent!

KERN: debug_server: Killing team 153 (/boot/system/servers/mail_daemon -E)
KERN: debug_server: TeamDebugHandler::Init(): Failed to get info for team 153: Operation on invalid team
KERN: debug_server: KillTeam(): Error getting info for team 153: Operation on invalid team
KERN: debug_server: Killing team 153 ()
USER 'liblocale.so'[197]: app application/x-vnd.Be-POST send to client failed: Bad port ID
KERN: bfs: bfs_create_index:2075: File or Directory already exists
KERN: Last message repeated 5 times.
USER 'liblocale.so'[379]: app application/x-vnd.Be-MAIL send to client failed: Bad port ID
KERN: runtime_loader: Cannot open file crypto: No such file or directory
KERN: runtime_loader: Cannot open file crypto.so.1.0.0: No such file or directory
KERN: runtime_loader: Cannot open file libcrypto: No such file or directory
KERN: runtime_loader: Cannot open file ssl: No such file or directory
KERN: runtime_loader: Cannot open file ssl.so.1.0.0: No such file or directory
KERN: runtime_loader: Cannot open file libssl: No such file or directory
KERN: runtime_loader: Cannot open file resolv: No such file or directory
KERN: runtime_loader: Cannot open file resolv.so: No such file or directory
KERN: runtime_loader: Cannot open file libresolv: No such file or directory
KERN: runtime_loader: Cannot open file libresolv.so: No such file or directory
KERN: slab memory manager: created area 0xf0001000 (9866)
USER 'liblocale.so'[413]: app application/x-vnd.Haiku-About send to client failed: Bad port ID

comment:3 by axeld, 7 years ago

The error image you attached is a generic dialog that opens for every crashing application - it's completely useless to copy here, though :-)

When this happens the next time, please press the "Debug" button, and attach the output of the "bt" command. It's not very user friendly, so sorry for that.

in reply to:  3 comment:4 by Giova84, 7 years ago

Replying to axeld:

The error image you attached is a generic dialog that opens for every crashing application - it's completely useless to copy here, though :-)

When this happens the next time, please press the "Debug" button, and attach the output of the "bt" command. It's not very user friendly, so sorry for that.

Output of "bt":

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/servers/mail_daemon (1007) thread mail_daemon (1007)]
0x02207848 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
(gdb) bt
#0  0x02207848 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#1  0x022077e9 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#2  0x0220bdc0 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#3  0x18057f90 in ?? ()
#4  0x00000003 in ?? ()
#5  0x008739ad in free () from /boot/system/lib/libroot.so
#6  0x022044ab in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#7  0x18057f90 in ?? ()
#8  0x02209262 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#9  0x00000000 in ?? ()
#10 0x02204491 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#11 0x0220bdc0 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#12 0x18057f90 in ?? ()
#13 0x7ffee968 in ?? ()
---Type <return> to continue, or q <return> to quit---
#14 0x00318b26 in BMessenger::BMessenger ()
   from /boot/system/lib/libbe.so
#15 0x022042f4 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#16 0x18057f90 in ?? ()
#17 0x005098c0 in BLooper virtual table ()
   from /boot/system/lib/libbe.so
#18 0x7ffee96c in ?? ()
#19 0x022042d2 in ?? ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#20 0x0021e2e0 in ?? ()
#21 0x7ffee90c in ?? ()
#22 0x1801cfc8 in ?? ()
#23 0x002169ef in MailDaemonApp::_RemoveAccount ()
#24 0x00216a3f in MailDaemonApp::_RemoveAccount ()
#25 0x002168be in MailDaemonApp::_ReloadAccounts ()
#26 0x00213c91 in MailDaemonApp::MessageReceived ()
#27 0x0030b3e3 in BLooper::DispatchMessage ()
   from /boot/system/lib/libbe.so
#28 0x00301e1d in BApplication::DispatchMessage ()
   from /boot/system/lib/libbe.so
---Type <return> to continue, or q <return> to quit---
#29 0x0030cd51 in BLooper::task_looper ()
   from /boot/system/lib/libbe.so
#30 0x00300899 in BApplication::Run ()
   from /boot/system/lib/libbe.so
#31 0x002191bc in main ()

With a previous nightly (hrev 44070) mail_daemon doesn't gave me any error.

comment:5 by humdinger, 7 years ago

I'm having the mail_daemon crashing on shutdown for a very long time:

Thread 519 caused an exception: Segment violation
[...]
[Switching to team /boot/system/servers/mail_daemon (519) thread mail_daemon (519)]
0x021e57ea in POP3Protocol::SendCommand ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
(gdb) bt
#0  0x021e57ea in POP3Protocol::SendCommand ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#1  0x021e247b in POP3Protocol::Disconnect ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#2  0x021e22bc in POP3Protocol::~POP3Protocol ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#3  0x00216a9e in MailDaemonApp::_RemoveAccount ()
#4  0x00212f69 in MailDaemonApp::~MailDaemonApp ()
#5  0x00219152 in main ()

It's not crashing when fetching or sending mail. But since Tue, 05 Jun 2012 17:23:06 the mail_daemon doesn't fetch mail from gmail.com anymore. No error messages. Another account at gmx.de works... This is hrev44214 I've been using for over a week.

comment:6 by diver, 7 years ago

See #8610.

comment:7 by Giova84, 7 years ago

hrev44240 the problem is still present. And now i notice that when i open any received mail, there is no content, the mail appear empty and after few second the message is closed automatically (without any error).

comment:8 by humdinger, 7 years ago

Did you run a checkfs? Maybe it's some filesystem corruption. My mail_daemon crashes only when quit... I can check my email accounts, though the bloody gmail account still doesn't send all those mails waiting there. /me doesn't like GMail webinterface too much :(

in reply to:  7 comment:9 by diver, 7 years ago

hrev44240 the problem is still present. And now i notice that when i open any received mail, there is no content, the mail appear empty and after few second the message is closed automatically (without any error).

I had the same problem until I unchecked "Partially download messages larger then" in E-Mail -> Incoming settings.

comment:10 by Giova84, 7 years ago

I run a checkfs but this doesn't solve nothing.. mail_daemon still crash when i change email prefs, sometimes when i receive mails and when i shutdown Haiku. I have unchecked "Partially download messages larger than" but sometimes the problem still occurs. In anyway, since i've set again my hotmail account (with mail_daemon works only in pop3 mode) all whole emails in my account have been downloaded again! So all emails were duplicated!

comment:11 by Giova84, 7 years ago

hrev44295: the behavior seems changed: now for me mail_daemon crashs only if i add accounts in mail prefs.. If i delete my mail accounts, mail_daemon no longer crash on reboot and on shutdown. But now, if i try to kill/quit mail_daemon, mail prefs icon stay in the deskbar.. For now i've solved using webmail and this notifier: http://haikuware.com/directory/view-details/internet-network/email/check-gmail

comment:12 by humdinger, 7 years ago

I "solved" my mail_daemon not fetching mails from Gmail by using Beam to check those mails. Which, of course doesn't set the MAIL:thread attribute and doesn't handle MAIL:status correctly... Haiku's mail system seems to be FUBAR...

comment:13 by Giova84, 2 years ago

Although I'm using Beam to manage my mails (the mail_daemon doesn't work with Gmail, at least for me), I've no longer seen the issue of this ticket, because I've attempted to setup again the mail_daemon, and this time didn't crashed.

comment:14 by waddlesplash, 11 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.