Opened 5 years ago

Last modified 6 months ago

#8689 assigned bug

[E-mail] preflet deadlocks

Reported by: diver Owned by: Nobody
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc: Stephan Aßmus
Blocked By: Blocking: #13575
Has a Patch: no Platform: All

Description

This is hrev44294 gcc2 hybrid.

  • Start E-mail
  • Select E-mail filters
  • Click Add filter
  • Click • Incoming

At this point preflet deadlocks.

Change History (8)

comment:1 Changed 5 years ago by diver

Cc: Stephan Aßmus added

Starting E-mail in Terminal and killing it after deadlock using Ctrl+C leaves visual artifacts in Terminal window.

comment:2 Changed 5 years ago by diver

Actually this deadlock happens with any open menu.

comment:3 Changed 5 years ago by diver

Component: Preferences/E-mailKits/Interface Kit
Owner: changed from Bruno Albuquerque to axeld

Same problem in Media preflet:

  • open Audio mixer -> Setup
  • click Resampling algorithm dropdown menu
  • click Audio settings in MediaListItem view

this will deadlock Media.

comment:4 Changed 11 months ago by diver

Resolution: fixed
Status: newclosed

Can't reproduce anymore. Likely fixed in the meantime.

comment:5 Changed 11 months ago by diver

Seems I was to quick with closing it, it's still reproducible in hrev50840.

comment:6 Changed 11 months ago by luroh

Resolution: fixed
Status: closedreopened

comment:7 Changed 8 months ago by axeld

Owner: changed from axeld to Nobody
Status: reopenedassigned

comment:8 Changed 6 months ago by diver

Blocking: 13575 added
Note: See TracTickets for help on using tickets.