Opened 7 years ago

Closed 9 months ago

#8725 closed bug (fixed)

Media playback slow and choppy if network device is enabled

Reported by: dcatt Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/ralinkwifi Version: R1/Development
Keywords: Cc: dcatt
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have noticed with Haiku Alpha 3 that media playback (e.g., audio OR video) is slow and choppy if my network device is enabled (connected to the network or not). Someone in the forums suggested I should try a nightly build, so I did via running in live desktop mode and I still experience the issue.

OS Version: R1/alpha3 (Revision 42211) & haiku-nightly-hrev44318-x86gcc2hybrid (2012-07-11)
Hardware;

  • CPU: AMD Athlon XP (1.15 GHz)
  • Memory: 1024 MB (PC133 SD-RAM)
  • Network Device: RT2500 802.11g (Ralink corp.)
  • Sound Device: VT82C686 AC97 Audio Controller (Via Technologies)

Steps to Reproduce

  1. enable network device
  2. playback a media file (audio OR video) using the MediaPlayer
  3. observe that the playback is slow and choppy
  4. disable the network device
  5. observe that the playback is normal

Expected Results: I would expect media playback to be normal regardless if any other device is enabled or not.

Actual Results: If the network device is enabled, then media playback is slow and choppy.

Attachments (2)

syslog.txt (39.9 KB ) - added by dcatt 7 years ago.
screenshot1.png (34.0 KB ) - added by dcatt 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by dcatt, 7 years ago

Cc: dcatt added

comment:2 by diver, 7 years ago

Please attach your syslog and a screenshot of the "Threads and CPU usage" in ProcessController when playback is choppy.

comment:3 by ttcoder, 7 years ago

Likely a new symptom of #8007 ; though maybe in this case there is a way to alleviate the problem with changes/optimizations in the network device driver.

comment:4 by diver, 7 years ago

Version: R1/alpha3R1/Development

by dcatt, 7 years ago

Attachment: syslog.txt added

by dcatt, 7 years ago

Attachment: screenshot1.png added

comment:5 by dcatt, 7 years ago

Okay... attached is a snapshot of the syslog during playback with network device enabled as well as a screenshot of the Threads and CPU usage.

comment:6 by diver, 7 years ago

Component: Audio & VideoDrivers/Network/ralinkwifi

comment:7 by korli, 6 years ago

Could you try with a current nightly and disable the serial log output? For the latter, see the kernel settings file, uncomment the line serial_debug_output.

comment:8 by waddlesplash, 9 months ago

Resolution: fixed
Status: newclosed

Most of those debug prints have been disabled, and a lot of other stray interrupts were disabled, and otherwise this sounds like a duplicate of #14270 which was fixed.

Note: See TracTickets for help on using tickets.