Opened 7 years ago

Closed 4 years ago

#8726 closed bug (fixed)

Tracker exhibits funky behavior

Reported by: dsuden Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

OK, funky isn't the best word. Here's what I've been seeing in more than one different build of Haiku...

After a period of use, the icons on the desktop will darken if I click on them, but they won't undarken if I then click on a different icon, thus I end up with more than one darkened icon. This issue is always accompanied by my being unable to drag icons around. However if I double-click on an icon, such as a folder, it will still open. After doing so, that icon will join the ranks of other icons on the desktop that are darkened.

Attachments (1)

Tracker_multiple_editor-widgets.png (8.7 KB) - added by ttcoder 6 years ago.
here's what my Desktop up-left looks like right now, after hitting Alt-E on a couple files

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by anevilyak

Component: SystemApplications/Tracker
Owner: changed from nobody to aldeck
Status: newassigned

Possibly related to #8714

comment:2 Changed 7 years ago by axeld

Could you test if Tracker is running twice? I remember having seen "funky" stuff as well (this was back in BeOS, though), and the usual reason was that it indeed ran twice.

comment:3 Changed 7 years ago by diver

Summary: Desktop (Tracker?) exhibits funky behaviorTracker exhibits funky behavior

I have the same problem in hrev44419.

comment:4 Changed 7 years ago by X512

Does pressing and releasing Ctrl and Alt buttons solve problem?

comment:5 Changed 7 years ago by dsuden

axeld I can confirm that when I experience the problem described in this ticket, that I see TWO versions of Tracker showing up in ProcessController. Killing one of them solves the problem. So that leaves the sticky question, eh? Why do two Trackers occur?

comment:6 Changed 7 years ago by dsuden

Still happening in A4

axeld I have just seen this behavior in Alpha 4. I selected a desktop icon and then couldn't deselect it, it stayed dark no matter what I did. I opened ProcessController and sure enough, two copies of Tracker were running. When I killed one of them, I could then select and deselect the icon normally.

comment:7 Changed 7 years ago by axeld

I haven't seen this bug since I run Haiku instead of BeOS - can you do some more investigations when this happens next time? Like if 'ps' in a Terminal shows the same application path, etc.

comment:8 Changed 6 years ago by ttcoder

(should I get in IRC and link up with anyone about this? I'll be online for 1+ more hour)

Hey! I have Tracker playing "funky chicken" on me right now as I'm typing this :-p.. Can't find the exact ticket about the symptoms (not sure it exists actually) but I remember this one is close enough.

First, here's my "ps":

~> ps | grep Tracker
/boot/system/Tracker                                 130       23    0    0

So only one instance. Next, the screenshot of said symptoms... which never occured before I upgraded to Alpha 4.1, if that's any useful to know..

Changed 6 years ago by ttcoder

here's what my Desktop up-left looks like right now, after hitting Alt-E on a couple files

comment:9 Changed 6 years ago by ttcoder

This occured while I was working on #9434, preparing files on the Desktop ..etc. Basically now I have to do all my file renaming elsewhere (e.g. in a newly created folder, made using Alt-N, which incidentally ends up being named something else than "New Folder" because this bug also impacts the editor-widget that pops up on new folders! :-)

Basically the behavior I see is, 1) the editor widget is somewhat "persistent" (there can be multiple displayed at the same time, though older ones tend to disappear in some use-cases), and 2) Tracker editor-widget is always "one step behind", the newest instantiated one contains the file name of the previously named file; in fact the names seem to "stack up" (there's some recursion somewhere maybe??) and if you hit Alt-E several times then you "unwind" the stack.

Confusing description I'm sure... Best to diagnose this in IRC or something I guess.

comment:10 Changed 6 years ago by korli

Could you check on hrev44899 or newer? It could be related.

comment:11 Changed 5 years ago by waddlesplash

Any update on this?

comment:12 Changed 4 years ago by dsuden

I don't think I've seen any of this for quite awhile. Maybe this one could be shifted out of active for now.

comment:13 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.