Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8737 closed bug (fixed)

Web+: Right click and "save link to disk" not working anymore / Downloads window issues

Reported by: cian Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using hrev44339 with the now supplied Web+, right clicking and selecting "save link to disk" doesn't work anymore.

Downloads caused by clicking on a link complete properly but the Downloads window does not detect them as having finished - they will show as active, and show "restart" if you cancel them even though the files are complete.

Change History (8)

comment:1 by anevilyak, 7 years ago

Owner: changed from leavengood to aldeck
Status: newassigned
Version: R1/alpha3R1/Development

comment:2 by anevilyak, 7 years ago

These both look to be regressions in the updated WebKit port we're now using.

comment:3 by jstressman, 7 years ago

Just verifying that I'm seeing both these bugs, and adding myself to the ticket.

comment:4 by aldeck, 7 years ago

Resolution: fixed
Status: assignedclosed

Fixed in haiku-webkit 5a75e8b and 16691d8

Will upload the updated OptionalBuildPackage asap.

https://github.com/aldeck/haiku-webkit/commit/16691d8 https://github.com/aldeck/haiku-webkit/commit/5a75e8b

in reply to:  4 ; comment:5 by Giova84, 7 years ago

Replying to aldeck:

Fixed in haiku-webkit 5a75e8b and 16691d8

Will upload the updated OptionalBuildPackage asap.

Hi Aldeck, can you check "haikuwebkit-1.1.3-x86-gcc4-2012-07-20.zip"? Seems to be an invalid/corrupted zip file, since Expander don't see any valid content in this archive.

Regards.

in reply to:  5 ; comment:6 by anevilyak, 7 years ago

Replying to Giova84:

can you check "haikuwebkit-1.1.3-x86-gcc4-2012-07-20.zip"? Seems to be an invalid/corrupted zip file, since Expander don't see any valid content in this archive.

That's because I was in the middle of uploading it. Please don't just grab random packages off that server, there's no guarantee they'll actually work with your current revision of haiku.

in reply to:  6 comment:7 by Giova84, 7 years ago

Replying to anevilyak:

Replying to Giova84:

can you check "haikuwebkit-1.1.3-x86-gcc4-2012-07-20.zip"? Seems to be an invalid/corrupted zip file, since Expander don't see any valid content in this archive.

That's because I was in the middle of uploading it. Please don't just grab random packages off that server, there's no guarantee they'll actually work with your current revision of haiku.

You're right and i'm agree with you: but i'm trying just for testing purposes and i have a full system backup to go back again to a functional system :-)

comment:8 by Giova84, 7 years ago

If you want to keep off users from that server, find a way to restrict access :-). And in anyway i'm not "grabbing" random files; i'm just picking what i think could be useful for my installation, in this situation to fix WebPositive issue, described in this ticket. This is not a criticism, it's just my motivation, don't you worry!

Kind regards.

Note: See TracTickets for help on using tickets.