Opened 7 years ago

Closed 7 years ago

#8769 closed enhancement (no change required)

Add 24 hour time preference under "Time preferences" where time preferences belong.

Reported by: jstressman Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Time & Date Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7331
Has a Patch: no Platform: All

Description

Pardon the length, but I want to drive this point home unequivocally.

First of all I am not saying that it shouldn't be under Locale as well. I'm saying that it should absolutely also be under Time preferences.

It is design error to put a Time setting under Locale preferences alone and nowhere else (namely not putting it under the Time preferences).

I and other people in the chat just now went to the Time settings (right clicking the clock and choosing Time preferences to change the settings of the clock's display) to see if there is an option to change to 24 hour format and didn't find it, thus assuming the option didn't exist.

A user shouldn't have to dig through other system preferences or documentation to find out that there is such a setting under Locale preferences, nor should they be required to know about locales and their relation to time keeping notations. Such a setting should be in the simplest, most obvious location and require no additional technical knowledge or searching from the user to find it.

The Locale setting definitely can and should set a default format based on locale, but the ability to switch between 12 and 24 notation manually after that should be in the most obvious place one would go to change a time preference. The Time preferences.

Again, it can certainly be in both places, but not putting it in the most obvious place is a usability error.

Sadly Windows suffers this exact same failure, and you can thusly see people asking for help to make such a simple change... with well over 2,000,000 hits on google for what should be a completely simple and intuitive option change. Walkthroughs, tutorials, guides, etc... for this single tiny setting change.

Here is a telling example of how this failure is viewed: "It’s really very simple to enable the system clock to show military time in Windows 7 or Vista, but the setting is not in an obvious place, so you might not have found it." and there are countless other examples of people trying to figure out how to make this simple change.

Let's please not make the same mistake.

Further...

From http://en.wikipedia.org/wiki/24-hour_clock#Military_time

"The 24-hour clock is commonly used there only in some specialist areas (military, aviation, navigation, tourism, meteorology, astronomy, computing, logistics, emergency services, hospitals), where the ambiguities of the 12-hour notation are deemed too inconvenient, cumbersome, or outright dangerous, with the military's use being the most famous example."

It's the international standard, countless people and fields use it related to their personal preference or their work or general fields of interest etc... not to their locale/region in their mind.

People want to change their clock. They don't want to have to think through what other technical issue might relate to that setting.

They think "I want my clock to show 24 hour, so I'll go into the preferences and switch it from 12 to 24." then they don't find that... so they go on google and start searching for a tutorial on how to possibly make a change that should have been made in a matter of seconds in the first place they and countless other people like them went looking for it.

There shouldn't need to be tutorials and guides etc for how to find and change such a simple Time preference in the literal sense.

Here is an example given for why real usability problems aren't fixed, and it's one I think we're likely to hear in relation to this on... and one that is accordingly incorrect and invalid;

"Usability Problems Get Dismissed As Training Issues

A convenient way for an organization to avoid fixing usability problems is to dismiss them as training issues. Believing that problems are training issues supposes that the problems aren’t in the software, they’re in the users. Users just need to learn how to use the software, and that would take care of all the problems. An even lazier and less expensive solution is declaring something a communication issue. People just need to be told the right way to do something."

The problem is in software. The solution is to add a simple tiny option under Time preferences to switch the display mode between 12 and 24 hour. Not to expect the users to understand locale preferences, or to go do research to learn about it or figure out where in the system such a simple setting is actually changed.

"Effective interfaces do not concern the user with the inner workings of the system."

Put the 12/24 hour time preference in the most obvious place. The Time preferences.

Put another way, if a person wanted to change their clock to 24 hour format in real life, they'd look for a switch on it... their mind, at least in this country, would be about the TIME itself... finding 24 hour more logical than 12 as a personal preference... or about their field of work... medicine, military, etc... but it almost surely would not first think about "Locale". It would think about the clock itself and switching the mode on it. People extend this life experience to the computer when it comes to such simple things as changing the time... they change the time itself on the clock, and flipping the mode from 12 to 24 seems to logically follow to be done the same way... not going and finding some "where are you?" setting that has it buried under that. They don't feel like they're changing their time zone. They're not changing where they are. They're just changing the display on the clock itself.

Now just to really drive this point home, I did a survey of users across several chats I'm in on IRC, XMPP, etc. Half of which are even technical people. Several XMPP developers, a lead Rackspace technician, a video production engineer... and several Japanese language learners to balance it out. 11 responses. These are all intelligent people and most of them are either exceptionally knowledgeable about computers, or about differences in languages, regional differences, etc.

And guess what the unanimous response was?

Every single one first said that they'd go to the clock options in the system tray. Second to that they'd try to look for "Time and Date" preferences.

Only one single person said they would try Region/Locale if they couldn't find it under clock settings (a Japanese language learner familiar with regional settings), and one user (an XMPP developer) after thinking about it after it was explained said that it made sense to also be there, but that it should really be in the first place every single person said they'd look; under the options for the clock itself.

In fact at least Gnome Shell and XFCE on Linux do this;

http://i32.photobucket.com/albums/d12/phreadom/gnomeshelldateandtime1.png

http://i32.photobucket.com/albums/d12/phreadom/xfce-datetime-properties.png

In closing, I think the lead Rackspace technician put it pretty succinctly when he responded "if the 'time settings' are located anywhere other than the 'thing that presents the time' its f#@%tarded."

A bit blunt, but I think it sums it up.

Put the Time preferences under the Time preferences.

Thanks.

Attachments (1)

beosr5clock.png (7.6 KB ) - added by jstressman 7 years ago.
Even BeOS R5 gets it right.

Download all attachments as: .zip

Change History (8)

comment:1 by jstressman, 7 years ago

Following up on how users feel about Windows' failure on this matter... look at the comments on this article on it: http://hansengel.wordpress.com/2007/08/18/random-setting-xp-to-use-24-hour-clock/

Here are just a few of them, aside from all the more general thank yous...

  • big thanx man,i was searchin this for hours
  • thanks much, I too was looking for this!
  • Thnx man, was googling this up
  • Nice one. Just re-installed XP and AM was bugging me.
  • Thanks I was wondering how to do this.
  • Thanks,friend... Me and a friend of mine were trying for ours to fix it...
  • Many thanks, I have been pulling out my few remaining hairs trying to figure how to select 12/24 hour format.
  • Thank you very much, I had no idea where they hid this setting!
  • was lookin’ for this for ages. Thank you
  • Thanks dude. Cut down my digging through the control panel.
  • Thanks heaps! Why this is not adjustable via the “control panel – date and time” is beyond me???? Idiot programers I suppose...
  • Thanks! That’ll work for and ol’ Army guy...
  • I too was reinstalling XP (for speed-up purposes) and couldn’t remember how I had done it before. Awesome to have military time back.
  • Thanks for the tip. It is a lot better than garbaging up my computer with another app. and is useful for Amateur Radio, where schedules are given in 24 hour time.
  • thanx alot. why on earth would they hide this option so far. it should be right there when you right click the clock for options.
  • Hi, THX for your input on the net. I was looking around in so many places. THX a lot
  • BIG thumbs up. This was bothering me for a LONG time
  • You are the best ever man, searched on my comp for hrs trying to figure this out.
  • Couldn’t figure this out forever.. Karma point for you.. Thx
  • Thank you! I had forgotten how to do that, it’s been too long.

Do we really want to have Haiku also be so unintuitive that it goes against almost everyone's obvious first instincts on how to change a Time setting?

I really hope this puts the issue to rest and we can get it fixed.

Thanks again.

comment:2 by jstressman, 7 years ago

And my quiz included people from US, UK, Lithuania, the middle east, and so on. I wanted to get a general spread, including countries that already default to 24 hour format. It didn't really make a difference. Everyone thought to go to the clock itself first.

comment:3 by jstressman, 7 years ago

And if none of those arguments convince you...

Let's look at what BeOS R5 does. It puts it right in the right click menu on the clock itself, you don't even have to go into the Time & Date preferences... it's right there before anything else.

by jstressman, 7 years ago

Attachment: beosr5clock.png added

Even BeOS R5 gets it right.

comment:4 by jstressman, 7 years ago

http://www.freelists.org/post/haiku-commits/haiku-hrev43984-srcappsdeskbar

That is apparently the discussion that led to this being removed again.

What that doesn't take into account however is that this is not merely a subjective change like whether or not someone likes the AM or PM showing, or if they want some separator other than :, or if they want to show seconds or not.

This is a standard time keeping format that is a necessity in numerous fields in every country around the world, regardless of what other standard they might use. It is a fundamentally basic option.

Treating it like some meaningless fluff tweaking option totally fails to understand the issue at hand.

comment:5 by axeld, 7 years ago

Wow, this really seems to be important to you :-)

Anyway, I completely agree that our current solution to spread the time settings in several places is just a bad idea.

OTOH as pointed out in the discussion, it's also a bad idea to let the options that are in the Deskbar have system wide consequences. It's still a good thing to have system wide setings for this, too, though. I'm not really sure what the best solution is to this problems, but ideas and suggestions are welcomed.

comment:6 by jscipione, 7 years ago

Blocking: 7331 added

(In #7331) All of the clock options including 12/24 hour (currently found in Locale), show seconds, and show day of week should be consolidated into Time Preferences. Once that is done this mockup seems more reasonable so I am making this ticket depend on #8769.

comment:7 by jscipione, 7 years ago

Resolution: no change required
Status: newclosed

Closing this as invalid as it has been discussed to death with the only consensus being that 12/24 hour clock setting should NOT go in Time. See http://www.freelists.org/post/haiku-development/Moving-clock-options-to-Time-Preferences for discussion.

Note: See TracTickets for help on using tickets.