Opened 13 years ago

Closed 12 years ago

#881 closed bug (fixed)

[Tracker] folder's content jumps on window resize

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Folder's content jumps on window resize, this bug appears about a month ago.

Attachments (1)

error (1.3 KB ) - added by diver 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 by axeld, 13 years ago

Could you go into more detail? I can't imagine what you mean. Is it possibly related to that (fixed) bug: http://sourceforge.net/tracker/index.php?func=detail&aid=1155913&group_id=36106&atid=416230

?

in reply to:  1 comment:2 by diver, 13 years ago

Replying to axeld:

Could you go into more detail? I can't imagine what you mean. Is it possibly related to that (fixed) bug: http://sourceforge.net/tracker/index.php?func=detail&aid=1155913&group_id=36106&atid=416230

Nope, this is not related to this bug. If i open home folder (don't remember in which mode now, sorry) and try to enlarge/shrink the window, icons with text will jump several times +-5-10 pixels in different directions util you stop resizing. I think this bug appear when Ingo merged his branch. Could be related to tracker changes made by Stephan (just a guess).

comment:3 by diver, 13 years ago

Ok, i even compiled current tracker from svn for target hrev5 and have the same (a little less) jumping on BeOS R5 too.

Also, to compile Tracker i had to comment 2 lines in Utilities.cpp at line 635
case B_ALIGN_HORIZONTAL_UNSET:
case B_ALIGN_USE_FULL_WIDTH:

See attached error message.

by diver, 13 years ago

Attachment: error added

comment:4 by genki0, 13 years ago

I am also verifying this.

The problem also exists in OpenTracker CVS at sourceforge. I've been running with OT 5.3.0 (August 2006) without this problem but today i updated to CVS and there it was.

The easiest way to reproduce is to set the view to list view, and then shrink/grow by resizing the window diagonally.

comment:5 by genki0, 12 years ago

Ok, I believe this bug was introduced by the fix in the sf.net bug above. I removed the ScrollBy() calls in BContainerWindow::FrameResized and the icon jumping went away.

comment:6 by diver, 12 years ago

Seems to be fixed now.

comment:7 by stippi, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.