Opened 13 years ago

Closed 13 years ago

#882 closed bug (fixed)

Bootloader failing to find usable partitions

Reported by: engima Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When running under qemu the Haiku bootloader does not appear to find a valid partition to boot off. An amount of debug partition scanning information is passed to serial output after which the graphical bootloader menu appears without listing any usable partitions, only allowing the reboot option.

This occurs with hrev18998 under Qemu, and there have been reports of failure running in real hardware in IRC. It appears to be a relatively recent issue as it worked fine around 20 revisions ago (Sorry I dont know the exact last revision it worked for me).

I'm building Haiku with GCC4 under Gentoo Linux. Attached is the serial log, note lines stating "intel: _ReadPTS(): bad offset: 0".

Attachments (1)

seriallog (3.1 KB ) - added by engima 13 years ago.
complete serial log

Download all attachments as: .zip

Change History (3)

by engima, 13 years ago

Attachment: seriallog added

complete serial log

comment:1 by engima, 13 years ago

John Drinkwater noted it looks like hrev18991 may have introduced the problem. I reverted it locally and the system boots fine after this.

comment:2 by axeld, 13 years ago

Resolution: fixed
Status: newclosed

Thanks for the note! It should be fixed in hrev19000.

Note: See TracTickets for help on using tickets.