Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#8827 closed bug (fixed)

DriveSetup allows corruption of mounted filesystems

Reported by: kallisti5 Owned by: waddlesplash
Priority: high Milestone: R1/beta1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

To reproduce:

  • Initialize Intel Partition Map on disk
  • Create a new partition
  • Format partition as BFS
  • Mount partition
  • Format disk as BFS

Check for mounted file systems on disk doesn't occur and you get an invalid mount on the system.

Change History (6)

comment:1 Changed 7 years ago by anevilyak

This sounds more like something the kernel side of the disk systems should be forbidding, since that's where all the actual initialization work happens.

comment:2 in reply to:  1 Changed 7 years ago by bonefish

Component: Applications/DriveSetupSystem/Kernel
Owner: changed from stippi to axeld

Replying to anevilyak:

This sounds more like something the kernel side of the disk systems should be forbidding, since that's where all the actual initialization work happens.

It is: http://cgit.haiku-os.org/haiku/tree/src/system/kernel/disk_device_manager/ddm_userland_interface.cpp#n1252

comment:3 Changed 5 years ago by waddlesplash

Owner: changed from axeld to waddlesplash
Status: newassigned

comment:4 Changed 5 years ago by waddlesplash

Milestone: R1R1/alpha5

comment:5 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Fixed in hrev48138.

comment:6 Changed 5 years ago by pulkomandy

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.