Opened 7 years ago

Closed 5 years ago

#8852 closed enhancement (fixed)

ifconfig adds non-existant network devices to networkstatus applet

Reported by: edglex Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

If you run ifconfig with a typo, e.g.

ifconfig /dev/net/atheroswifi/ down

the deskbar network applet will get a new (erroneous) device entry "/dev/net/atheroswifi/: No link"

I don't know if the bug is in ifconfig or the deskbar applet, so I dropped it into networkstatus. I would think ifconfig should tell you that you didn't use a real network device... maybe this is two bugs?

Change History (4)

comment:1 by anevilyak, 7 years ago

Component: Applications/NetworkStatusNetwork & Internet/Stack

comment:2 by axeld, 7 years ago

Type: bugenhancement

ifconfig can create arbitrarily named interfaces - that they have the same name as the device is merely for educating the user/convenience. So the basic functionality is not a bug.

One could only restrict the cases when ifconfig will in fact create a new interface. I'm not sure how other platforms deal with this in their ifconfig implementation. It might make sense to copy their behavior.

In any case, the shell is usually less forgiving than the UI, so the current behavior might just be okay.

comment:3 by jackburton, 5 years ago

I think I changed this behaviour of ifconfig in hrev47333. So, let's close this, or revert 056b2e33e5bde313ca2a9c2d0f2374c459aa10ac if you think it's not correct.

Last edited 5 years ago by jackburton (previous) (diff)

comment:4 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.