Opened 7 years ago

Closed 7 years ago

#8851 closed bug (duplicate)

Resizing media preferences window

Reported by: edglex Owned by: yourpalal
Priority: normal Milestone: R1
Component: Kits/Media Kit Version: R1/Development
Keywords: window, resize Cc:
Blocked By: #8656 Blocking:
Has a Patch: no Platform: x86

Description

If you make the media preferences window larger then close it, when you reopen it it remembers the size you left it at, but you cannot decrease it back to smaller than where you left it.

This is in contrast to e.g. appearance window, which always opens with the same size, cannot be reduced below that, and does not remember the size you left it at.

Change History (6)

comment:1 Changed 7 years ago by diver

Component: Preferences/MediaAdd-Ons/Media/Mixer
Owner: changed from anevilyak to yourpalal
Status: newassigned

comment:2 Changed 7 years ago by modeenf

Isn't this a Preferences/Media thing?

comment:3 Changed 7 years ago by diver

Media can't be resized only with Mixer view opened. So my guess would be that mixer use pre-layout API which should be fixed.

comment:4 in reply to:  3 Changed 7 years ago by anevilyak

Component: Add-Ons/Media/MixerKits/Media Kit

Replying to diver:

Media can't be resized only with Mixer view opened. So my guess would be that mixer use pre-layout API which should be fixed.

That's actually not the case, the media add-ons only export a "parameter web" which tells the media kit/media preflet how to build a configuration UI, the individual add-ons don't build the GUI themselves, and know nothing of it.

comment:5 Changed 7 years ago by diver

Ok, it might be a dupe of #8656 then.

comment:6 Changed 7 years ago by diver

Blocked By: 8656 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.