Opened 7 years ago

Closed 5 years ago

#8936 closed bug (fixed)

WebPositive is crashing when I browse to a site

Reported by: xray7224 Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by leavengood)

Hey,

I was using webpositive for a while, I've come to open it and browse around, it loads up fine and I enter a URL and it begins to load, part way through the debug dialogue comes up, It keeps doing this I have tried a handful of times (and different websites). I don't know what's wrong but entering gdb I get:

Reading symbols from /boot/common/lib/libssl.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libssl.so.1.0.0
Reading symbols from /boot/common/lib/libcrypto.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libcrypto.so.1.0.0
Reading symbols from /boot/common/lib/liblzma.so.5.0.1...done.
Loaded symbols for /boot/common/lib/liblzma.so.5.0.1
Reading symbols from /boot/common/lib/libiconv.so.2.5.0...done.
Loaded symbols for /boot/common/lib/libiconv.so.2.5.0
Reading symbols from /boot/system/lib/gcc4/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/WebPositive (15079) thread WebPositive (15079)]
0x0046e400 in WTF::Vector<unsigned char, 0ul>::reserveCapacity ()
   from /boot/common/lib/libjavascriptcore.so

(gdb) bt
#0  0x0046e400 in WTF::Vector<unsigned char, 0ul>::reserveCapacity ()
   from /boot/common/lib/libjavascriptcore.so
#1  0x00471e38 in _ZN3JSCL22arrayProtoFuncToStringEPNS_9ExecStateE ()
   from /boot/common/lib/libjavascriptcore.so
#2  0x18a2b868 in ?? ()
#3  0x7ffedc68 in ?? ()
#4  0x01000000 in WebCore::JSSQLExceptionPrototype::getOwnPropertySlot ()
   from /boot/common/lib/libwebcore.so
Previous frame inner to this frame (corrupt stack?)
(gdb) 

This happened on the dev release hrev44584 (I doubt i could get it to occur on a newer one as it just randomly began occurring after a good few days of use).

Change History (10)

comment:1 Changed 7 years ago by leavengood

Obviously this shouldn't happen, but just to help diagnose the problem, can you try deleting the BrowsingHistory file in /boot/home/config/settings/WebPositive? If you still have the crash then try deleting the WebpageIcons.db file in the same directory.

comment:2 Changed 7 years ago by leavengood

Description: modified (diff)

comment:3 Changed 7 years ago by xray7224

Removed both, it still happens.

comment:4 Changed 7 years ago by leavengood

Yeah looking at the backtrace again that was a bit of a shot in the dark. But it seems quite odd that it would work for a while and then start crashing. It makes me think it might be related to cookies. There should also be a Cookies.curl file in the directory I mentioned before. Try deleting that too.

comment:5 Changed 7 years ago by xray7224

I've deleted that and again it still occurs.

comment:6 Changed 7 years ago by aldeck

No idea what could be the problem at first glance, but in any case i'd rather keep those files and send them here instead of removing them.

comment:7 Changed 7 years ago by xray7224

I have deleted them sorry. It hasn't fixed the problem though so I doubt it's that.

comment:8 Changed 5 years ago by pulkomandy

Could you try again with a newer nightly build?

comment:9 Changed 5 years ago by xray7224

I'm unable to reproduce. I presume whatever the problem was it has been fixed.

comment:10 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.