Opened 7 years ago

Closed 10 months ago

#8935 closed enhancement (fixed)

HAIKU_INCLUDE_PATENTED_CODE is now useless

Reported by: leavengood Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #9658
Has a Patch: no Platform: All

Description

The HAIKU_INCLUDE_PATENTED_CODE define and its associated configure option --include-patented-code is now useless since freetype has now been moved out into an optional package.

I think it should be removed. But we all know how I feel about the patented code nonsense.

Change History (14)

comment:1 Changed 7 years ago by aldeck

Either way we need to provide a freetype package with subpixel aa enabled. I had to rebuild freetype from source to get subpixel aa working again here. Appearance preflet needs to be updated too.

comment:2 in reply to:  1 Changed 7 years ago by leavengood

Replying to aldeck:

Either way we need to provide a freetype package with subpixel aa enabled. I had to rebuild freetype from source to get subpixel aa working again here. Appearance preflet needs to be updated too.

Yeah that is on my list, maybe for alpha4. The incorrect text from the Appearance preflet should at least be removed. Also turning on the freetype subpixel filter (FT_Library_SetLcdFilter(fLibrary, FT_LCD_FILTER_DEFAULT);) really, really improves the rendering.

comment:3 Changed 7 years ago by scottmc

We could provide a secondary freetype optionalpackage if desired. What's the specific freetype configure option that you use for enabling this?

comment:4 Changed 7 years ago by aldeck

Yes that would be awesome. I'm not on my Haiku box right now, but that should be in freetype2/freetype/config/ftoption.h by uncommenting the define FT_CONFIG_OPTION_SUBPIXEL_RENDERING.

comment:5 Changed 7 years ago by scottmc

added a bep file to Haikuports to build with the subpixel rendering enabled. I'll leave it to someone from a FREE COUNTRY to build and upload the built files for gcc2 and gcc4.

comment:6 Changed 7 years ago by axeld

So HAIKU_INCLUDE_PATENTED_CODE is still relevant then -- it should choose the right optional package depending on it It .may still be used in the future for other code in the repository as well.

comment:7 Changed 6 years ago by anevilyak

Blocking: 9658 added

(In #9658) Duplicate of #8935.

comment:8 in reply to:  5 Changed 6 years ago by Giova84

Replying to scottmc:

added a bep file to Haikuports to build with the subpixel rendering enabled. I'll leave it to someone from a FREE COUNTRY to build and upload the built files for gcc2 and gcc4.

I live in Italy. If the patents permit, i can build and upload :-)

comment:9 Changed 6 years ago by X512

Since May 2010 patents to subpixel rendering are expired so HAIKU_INCLUDE_PATENTED_CODE is now useless. Subpixel rendering could be enabled without law violation in any country.

Reference: http://www.freetype.org/patents.html

comment:10 Changed 6 years ago by Giova84

So it's time to enable it in Haiku :-)

comment:11 in reply to:  9 ; Changed 6 years ago by umccullough

Replying to X512:

Since May 2010 patents to subpixel rendering are expired so HAIKU_INCLUDE_PATENTED_CODE is now useless. Subpixel rendering could be enabled without law violation in any country.

Reference: http://www.freetype.org/patents.html

As that page clearly shows - only the hinting patents are free now - the subpixel rendering may likely be covered by the ClearType patents, which it specifies are still in effect and would require using a different color filter to evade.

comment:12 in reply to:  11 Changed 6 years ago by X512

Replying to umccullough:

As that page clearly shows - only the hinting patents are free now - the subpixel rendering may likely be covered by the ClearType patents, which it specifies are still in effect and would require using a different color filter to evade.

Does complete hinting bytecode interpreter enabled by default? Why not to enable this different color filter? This is probably better than nothing...

Also does rendering glyph outlines with subpixel antialiasing by AGG violate patents?

comment:13 Changed 5 years ago by egrath

Eventually a proper solution would be to provide two versions of the package: One which has Subpixel Rendering and Hinting disabled and is installed by default. Another one in the repository which has it enabled and can be installed by users who live in a country where there are no software patents (most of the world except US and a few others).

Last edited 5 years ago by egrath (previous) (diff)

comment:14 Changed 10 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Removed in hrev52014.

Note: See TracTickets for help on using tickets.