Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8942 closed bug (fixed)

KDL - Panic: no space in log after sync

Reported by: tidux Owned by: axeld
Priority: blocker Milestone: R1/alpha4
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #8910 Blocking: #8961, #8969, #8988, #8998
Has a Patch: no Platform: All

Description

I attempted to run the "install-tl" script as described here: http://pulkomandy.lexinfo.fr/~texlive/

but received a KDL partway through. Luckily, this happened in a virtual machine, so here's a screenshot.

Attachments (2)

KDL.png (169.8 KB) - added by tidux 7 years ago.
KDL during Texlive installation
Haiku-2012-09-18-14-34-51.png (64.2 KB) - added by scottmc 7 years ago.
KDL - PANIC: no space in log after synce - running unzip

Download all attachments as: .zip

Change History (27)

Changed 7 years ago by tidux

Attachment: KDL.png added

KDL during Texlive installation

comment:1 Changed 7 years ago by anevilyak

Component: - GeneralSystem/Kernel
Owner: changed from nobody to axeld

Possibly related to #8910. Was the disk you were running that on running out of space?

comment:2 Changed 7 years ago by anevilyak

Version: R1/alpha3R1/alpha4

comment:3 Changed 7 years ago by tidux

I don't think so, the virtual hard drive was listed as having 2.7GB free. I also didn't see anything about failing asserts in my KDL message.

comment:4 Changed 7 years ago by mmadia

Version: R1/alpha4R1/Development

comment:5 Changed 7 years ago by anevilyak

Blocking: 8961 added

comment:6 Changed 7 years ago by anevilyak

Blocked By: 8910 added
Milestone: R1R1/alpha4
Priority: normalblocker

comment:7 Changed 7 years ago by axeld

Is this reproducible?

comment:8 Changed 7 years ago by leavengood

Scott got the same error three separate times as logged in #8961.

comment:9 Changed 7 years ago by axeld

I'm not questioning the severity, I'm just looking for a not too complex test case to reproduce it :-)

comment:10 Changed 7 years ago by scottmc

I suspect it's due to some change between hrev44573 and hrev44586, as I used hrev44573 and didn't get any KDLs while building many of the OptionalPacakges, but ran into it several times with hrev44586. I got both builds from mmadia as vmware images. He's reported similar issues in #8969.

As for a test case, just run in vmware using a clean install on a 2-3GB partition, then try to use installoptionalpackage and install all of the available apps... mine crashed part way through this. It could be a defective package (or packages), or something else completely.

comment:11 Changed 7 years ago by scottmc

@tidux, What version of Haiku were you using when this happened? Did you install anything prior to trying to build Texlive 2012, such as any dependency libraries or extra build tools?

comment:12 in reply to:  10 Changed 7 years ago by anevilyak

Replying to scottmc:

I suspect it's due to some change between hrev44573 and hrev44586, as I used hrev44573 and didn't get any KDLs while building many of the OptionalPacakges, but ran into it several times with hrev44586. I got both builds from mmadia as vmware images. He's reported similar issues in #8969.

No need to guess, it's due to the changes that tried to fix #8910.

comment:13 in reply to:  11 Changed 7 years ago by tidux

Replying to scottmc:

@tidux, What version of Haiku were you using when this happened? Did you install anything prior to trying to build Texlive 2012, such as any dependency libraries or extra build tools?

The version is in the ticket title. R1Alpha4-hrev44586 gcc2hybrid. The only optional packages I had installed were Vim and its dependencies.

comment:14 in reply to:  9 Changed 7 years ago by anevilyak

Replying to axeld:

I'm not questioning the severity, I'm just looking for a not too complex test case to reproduce it :-)

Over here I'm only able to reproduce it with something that causes a *lot* of disk activity, i.e. a haiku image build ; is there anything useful/of interest that could be pulled out of KDL that'd help? Perhaps with a debug BFS module?

comment:15 Changed 7 years ago by anevilyak

Blocking: 8988 added

(In #8988) Indeed.

comment:16 Changed 7 years ago by tidux

I reproduced this bug in a fresh VM, running R1A4-hrev44601 gcc2h. All I was doing to generate lots of disk activity was installing a long list of optional packages.

comment:17 in reply to:  16 Changed 7 years ago by scottmc

Replying to tidux:

I reproduced this bug in a fresh VM, running R1A4-hrev44601 gcc2h. All I was doing to generate lots of disk activity was installing a long list of optional packages.

Same here. This is easy to reproduce, just take a fresh vmware image, and install onto a larger 2-3GB vmware blank image, set that new image as the bootable partition. Then boot it. Open a terminal and type installoptionalpackages -l, to get the list of uninstalled packages, then run installoptionalpackage with the list of all of the uninstalled packages as parameters. Wait awhile... come back to the KDL. Note that I am able to 'cont' to resume after the KDL, but things are very unstable after that, with possible bit splatter for all I know, but it's vmware so I just delete the image and start over again.

comment:18 Changed 7 years ago by scottmc

Summary: KDL on R1A4-hrev44586 when trying to install Texlive 2012KDL - Panic: no space in log after sync

Changed 7 years ago by scottmc

KDL - PANIC: no space in log after synce - running unzip

comment:19 Changed 7 years ago by anevilyak

Blocking: 8998 added

comment:20 Changed 7 years ago by scottmc

Blocking: 8969 added

comment:21 Changed 7 years ago by axeld

Resolution: fixed
Status: newclosed

Should be fixed in hrev44649. The error does not explain the disk corruption that was reported in some of the tickets, but this should be an older problem, anyway.

comment:22 Changed 7 years ago by taos

Since I still see this panic in recent alpha4 nightly versions (e.g. hrevr1alpha4-44605) wouldn't it be a good idea to fix it also in the alpha4 branch? Whenever I try to build haiku on one of these revisions, after a few visits to KDL my build partitions can only be mounted as read-only...

comment:23 in reply to:  22 ; Changed 7 years ago by luroh

wouldn't it be a good idea to fix it also in the alpha4 branch?

The fix is being tracked for merging by leavengood, see https://dev.haiku-os.org/wiki/R1/Alpha4/MergeTracking

Hopefully he'll have time to merge it soon.

comment:24 in reply to:  23 Changed 7 years ago by leavengood

Replying to luroh:

wouldn't it be a good idea to fix it also in the alpha4 branch?

The fix is being tracked for merging by leavengood, see https://dev.haiku-os.org/wiki/R1/Alpha4/MergeTracking

Hopefully he'll have time to merge it soon.

Yeah I'll merge it today. I've been eagerly hoping for a fix for this issue so I could merge it. Thanks for the fix Axel!

comment:25 Changed 7 years ago by leavengood

This has now been merged in hrevr1alpha4-44607.

Note: See TracTickets for help on using tickets.