Opened 7 years ago

Closed 6 years ago

Last modified 10 months ago

#8943 closed bug (invalid)

Haiku crashes at boot on Acer Aspire X1200

Reported by: Luposian Owned by: xyzzy
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm including a full SysLog file, because the 64-bit version of Haiku seems to support saving the previous session, whereas I never could before on my 32-bit builds of Haiku.

Attachments (4)

Haiku64Crash.JPG (2.3 MB) - added by Luposian 7 years ago.
Panic screen
5560 crash.JPG (2.8 MB) - added by Luposian 7 years ago.
Crash/panic from Acer Aspire 5560 laptop (9/11/12) @ 12:22pm
SYSLOG00.TXT (44.9 KB) - added by Luposian 7 years ago.
Latest Syslog from 11/6/12
SYSLOG01.TXT (45.8 KB) - added by Luposian 6 years ago.
Syslog from Haiku 64-bit (hrev45222 (nightly)) on 1/31/13

Change History (70)

comment:1 Changed 7 years ago by anevilyak

Owner: changed from nobody to xyzzy
Status: newassigned
Version: R1/alpha3R1/Development

comment:2 Changed 7 years ago by anevilyak

What does the on-screen panic say? It doesn't appear to have made it into the log.

Changed 7 years ago by Luposian

Attachment: Haiku64Crash.JPG added

Panic screen

comment:3 Changed 7 years ago by xyzzy

What are you booting from? USB/CD/Hard disk? If CD or HD, do you know if the disk controller is in AHCI mode or legacy mode? Somebody else reported to me a while ago that the boot partition was not being found when booted from AHCI.

comment:4 Changed 7 years ago by Luposian

I'm booting from CD. The hard drive (SATA) is in AHCI mode. I will try Legacy Mode and see if that works. But the CD drive functions under hard drive modes as well? Didn't know that. Thought they had their own unique protocol to operate under.

comment:5 Changed 7 years ago by xyzzy

AHCI/legacy are modes of the SATA controller, not just one of the devices on it. If the CD drive is connected by SATA, then it'll be accessed through AHCI as well.

comment:6 Changed 7 years ago by Luposian

Upon searching, high and low, in the BIOS of my Acer Aspire X1200 desktop, there is absolutely NO option for changing the controller mode. It is what it is and that seems to be about it.

However, it DOES boot on my Acer Aspire 5560-7414 laptop (which uses an AMD A6-3420M CPU, no less), when I change the controller mode from AHCI to IDE (it refuses to boot, as well, if the mode switch is not made). So, there is further proof that what you were told about the controller type switch is correct and that Haiku (at least the 64-bit version) CAN work with that CPU type, too.

Funny thing is, Windows 7 has utterly NO clue how to deal with the controller switch from AHCI to IDE and thinks something is wrong and CAN'T fix it (HA!). Switching back to AHCI "fixed" everything though... thankfully.

But this ticket isn't about my laptop nor Windows, it's about my Acer Aspire X1200 desktop not booting in AHCI mode and no IDE mode is available, so... where do we go from here?

My assumption is that recompiling Haiku's AHCI driver for "Haiku64", would be the next logical step, but... is it?

Last edited 7 years ago by Luposian (previous) (diff)

comment:7 in reply to:  6 Changed 7 years ago by anevilyak

Replying to Luposian:

Funny thing is Windows 7 has utterly NO clue how to deal with the controller switch from AHCI to IDE and thinks something is wrong and CAN'T fix it (HA!). Switching back to AHCI "fixed" everything though... thankfully.

That's because of how Windows maps devices/drivers, you can't change that setting after having installed it (it'd be fine if you did a fresh install with that setting and just left it there then though).

My assumption is that recompiling Haiku's AHCI driver for "Haiku64", would be the logical next step, but... is it?

No, it's already included in there.

comment:8 Changed 7 years ago by xyzzy

So, that's the second report I've received that AHCI doesn't work. Which is interesting, considering I was regularly testing with AHCI in VirtualBox. I'll look into it tomorrow.

comment:9 Changed 7 years ago by Luposian

Summary: Haiku (64-bit) crashes at boot on my Acer Aspire X1200Haiku (64-bit) crashes at boot on Acer Aspire X1200

comment:10 Changed 7 years ago by diver

Component: - GeneralDrivers/Disk

comment:11 Changed 7 years ago by xyzzy

Just pushed a possible fix. In answer to your question on IRC, you can update the sources by running 'git pull' from the source directory (no need to checkout x86_64 again). When that finishes you should see in its output some changes to build/jam/FloppyBootImage. Then rerun jam to build a new image.

comment:12 Changed 7 years ago by Luposian

On my Acer Aspire X1200, it no longer boots. It sits at the "Boot from AHCI CD-ROM..." prompt forever, before eventually defaulting to Windows Vista. The CD drive light blinks incessantly, like it's trying to read something, but never does.

On my Acer Aspire 5560 laptop, however, it gets to the Haiku boot screen, and pauses on the 3rd icon for a few seconds before going to the 4th icon (disk w/ leaf) and then sits there forever. No crash/panic noticed.

On the X1200, it does nothing... on my 5560 laptop it gets to the 4th icon and stops. I don't understand why the two systems behave so differently during bootup. They both crashed similarly, with the previous version. But now one won't boot at all and the other one does, partially. Hmm...

My assumption is AHCI is AHCI... isn't it? Or are there different versions/implementations of AHCI? If that were the case, it could make trying to track down this bug, as difficult as trying to find a needle in a haystack!

comment:13 Changed 7 years ago by xyzzy

That sounds like the CD you're using is damaged or something. The change I made certainly should not cause that, all I did was add a driver to the image. Can you trying burning it on a different CD?

comment:14 Changed 7 years ago by tqh

Someone said disabling HPET worked when AHCI failed, see #8533. I wonder if this could be a problem:
In src/add-ons/kernel/drivers/timer/hpet.cpp

#define HPET64 0
[...]

#if HPET64
  //disable 32 bit mode
  timer->config &= ~HPET_CONF_TIMER_32MODE;
#else
  //enable 32 bit mode
  timer->config |= HPET_CONF_TIMER_32MODE;

comment:15 in reply to:  13 Changed 7 years ago by Luposian

Replying to xyzzy:

That sounds like the CD you're using is damaged or something. The change I made certainly should not cause that, all I did was add a driver to the image. Can you trying burning it on a different CD?

Well, I am using a CD-RW disc, but figured either it would work or it wouldn't. I will try using a CD-R disc as soon as possible and let you know my findings.

comment:16 Changed 7 years ago by axeld

CD-RWs can go bad after some use, even though in general there is nothing wrong with using them. You could also try to boot via USB, for example.

comment:17 in reply to:  16 Changed 7 years ago by Luposian

Replying to axeld:

CD-RWs can go bad after some use, even though in general there is nothing wrong with using them. You could also try to boot via USB, for example.

I've only reused this particular CD-RW a few times (5-6 times, at most, I figure). How many times can you usually write/erase a CD-RW before it becomes unreliable? They're Memorex 12x speed.

What program should I use, in Windows 7, to burn a Haiku USB image (Anyboot image, I assume)?

comment:18 Changed 7 years ago by Luposian

I burned the same version onto a CD-R and now it panics at the 4th icon (Acer Aspire 5560 laptop). There is no option shown, to save the syslog. I will test on my Acer Aspire X1200 desktop tomorrow and hopefully be able to save the syslog to USB, like last time.

comment:19 Changed 7 years ago by xyzzy

Was the panic the same as the one before?

comment:20 Changed 7 years ago by Luposian

I don't know. It crashes at the same point (4th icon), but I have no way of saving the syslog information, when I go into the Haiku Boot Options, after typing "reboot" at the KDL debug prompt. It just isn't there! I'm not up to taking snapshots of every page of text output that I can option. That's like 10-15 "pages" of pictures. Besides, this particular crash is on my Aspire 5560 laptop. Not part of this ticket. It's just a convenient "2nd environment", since they both use AHCI, natively. I will test on my Aspire X1200 desktop in a little while and let you know what happens. Hope I can save the syslog to USB like last time.

comment:21 Changed 7 years ago by Luposian

Ok, just tested on my Aspire X1200 desktop system. And... well, it just goes straight to Windows Vista after a few seconds. It gets to the "Boot from AHCI CD-ROM..." prompt, which then disappears, a couple seconds of black screen, and then the Windows Vista startup screen (scrolling green light bars). I rebooted to make sure it wasn't a glitch and it did it again.

So, we've gone from a Haiku bootup crash (1st version), to a lockup at the "AHCI CD-ROM prompt (2nd version on CD-RW), to absolutely no boot whatsoever (2nd version on CD-R).

And, of course, oddly enough, it acts different on my Aspire 5560 laptop, which crashes at the 4th icon, but I have no way of getting the Syslog easily.

This is just totally weird!

comment:22 Changed 7 years ago by xyzzy

That is very, very weird. Can I get a photo of just the first bit of the crash on the 5560 (showing the "PANIC:" line). Then can you try a clean rebuild? Run 'jam clean' then build the image again. I'm certain the change that I made should not be causing this to happen, all I did was add a few files to the image. No changes to any code.

comment:23 Changed 7 years ago by Luposian

You're probably gonna be shocked, but as far as I can tell, it looks like the crash is virtually (if not exactly) identical to the one I first posted (from my Aspire X1200 desktop). I'm posting the image after this reply.

I will attempt a "jam clean" and rebuild. I don't need to "git checkout x86_64" do I, after the jam clean?

Changed 7 years ago by Luposian

Attachment: 5560 crash.JPG added

Crash/panic from Acer Aspire 5560 laptop (9/11/12) @ 12:22pm

comment:24 Changed 7 years ago by xyzzy

No, you don't need to checkout again. You'll never have to run checkout in that repository again, unless you checked out a different branch yourself.

Tomorrow I'll do a build myself and double check that it's working on AHCI, if it is I'll upload it so you can try that, just to make sure it's not an issue with your build.

comment:25 Changed 7 years ago by Luposian

Remember, if you're using a VM and not real hardware, your AHCI may work perfectly on your end and fail on mine. If AHCI is implemented slightly differently on different chipsets (emulated or not), that could be the issue. If AHCI is AHCI, no matter what, then you simply need to test on real hardware, like my systems, til you get it nailed down.

I can give you more specifics (hardware specs) of my systems, if needed. Maybe that would help? I don't know if Windows Vista/7 can help describe hardware the way you need it, if so, but it's an option.

Let me know.

comment:26 Changed 7 years ago by xyzzy

Working fine for me booted from a CD drive on AHCI on my desktop. Try this build: http://alex-smith.me.uk/files/haiku-x86_64-anyboot-20120912.tar.xz

comment:27 Changed 7 years ago by Luposian

Ok, after creating the CD-R in K3B in Lubuntu (from your Anyboot image), the disc boots fine in AHCI, on my Aspire 5560 Laptop. But... upon testing it on my Aspire X1200 desktop, it wouldn't boot!

This didn't make any sense, until I noticed, the drive light never even blinked during bootup... and, upon trying to view ANY discs, they NEVER show up in Vista! When I try to open the drive (to view the contents of a given CD), in Windows Vista, it tells me device D: isn't ready or something!

My theory? My drive is dead! Overnight... just... POOF! Gone! I will try putting it on a different SATA channel later on, and see if that makes it work, but if not, then I need to get a new DVD drive, because I don't have a spare! And, right now, I don't have the money to buy a replacement, either, so... it may be awhile til we find out if the disc boots on that system, for which this ticket was created.

I could boot it from a USB thumb drive, I think, but that won't prove anything concerning AHCI on that system.

That being said, do we assume this ticket is closed (because it boots on my Acer Aspire 5560 laptop (that's actually an even BETTER situation than I hoped for!)) or do we leave it open til I can test it on the X1200 Desktop, which is the reason I opened this ticket to begin with?

comment:28 Changed 7 years ago by xyzzy

Good to know, not sure what could have happened before. Leave it open for now in case it still doesn't work on the desktop, just test it when you get a chance and let me know how it goes.

comment:29 in reply to:  27 Changed 7 years ago by axeld

Replying to Luposian:

My theory? My drive is dead! Overnight... just... POOF! Gone! I will try putting it on a different SATA channel later on, and see if that makes it work, but if not, then I need to get a new DVD drive, because I don't have a spare!

Sometimes it's just a loose cable. Anyway, good luck with it :-)

comment:30 Changed 7 years ago by Luposian

The thing that makes me happiest, is that "Haiku 64" boots perfectly on my Acer Aspire 5560 laptop. I never could get "Haiku 32" to boot on, nor my Gateway NV55S09u laptop before it (which I no longer own, so that ticket is kinda moot).

Since the crash happened at the same point (4th icon), is it possible that there is/was an IDE/AHCI issue with Haiku 32, too or...? Just a thought... :-D

Should I start making Anyboot images from now on, instead of .iso? Could that be part of my problem? Or is it more likely that my build environment (Lubuntu on an 8Gb USB stick) is the likeliest culprit?

comment:31 Changed 7 years ago by Luposian

Ok, just went out to the workshop and removed the drive, looking for a replacement cable. None are long enough, but... in my search, I found I DID have another SATA DVD drive! Kinda thought I did but couldn't find it initially.

Here's the summary: Plugged it in, with the cable from the other drive, inserted the Anyboot image disc and...

BINGO! It boots perfectly!

It was the drive.

Thus, this ticket can be considered CLOSED.

However, last two questions... should I be using a different environment (other than a USB stick) or...? I never had issues creating .iso's of 32-bit versions of Haiku in the past.

And second... any idea when a 64-bit version of WebPositive might be available, so I can web browse on my Aspire X1200 Desktop? It's wired up (Ethernet), with nowhere to go! :-(

comment:32 in reply to:  31 Changed 7 years ago by anevilyak

Replying to Luposian:

And second... any idea when a 64-bit version of WebPositive might be available, so I can web browse on my Aspire X1200 Desktop? It's wired up (Ethernet), with nowhere to go! :-(

That will probably be a while since there's a bit of work to be done to get WebCore building. For the time being you really don't gain anything from going with the 64-bit variant anyways, so I'd suggest just sticking to 32-bit builds until it's actually integrated back into the main tree. There are many other things that aren't yet 64-bit ready.

comment:33 Changed 7 years ago by xyzzy

Resolution: fixed
Status: assignedclosed

Don't know what could have caused the problem. I doubt it's a problem with the environment, only thing I can think of is that the fix didn't get pulled properly. But oh well, at least it's working now :)

comment:34 Changed 7 years ago by Luposian

Oops! Guess the issue is still alive... I just installed Xyzzy's Anyboot image (rather than just running it from the CD as before) and... BOOM! It crashes at the disk w/ leaf icon. I saved the Syslog and am including it with this reopening of the ticket.

It's taken this long to discover this, because I haven't had a 64-bit system I could devote to Haiku. Now I have two 64-bit desktop systems, so can devote the Acer X1200 solely to Haiku now.

comment:35 Changed 7 years ago by Luposian

Resolution: fixed
Status: closedreopened

Changed 7 years ago by Luposian

Attachment: SYSLOG00.TXT added

Latest Syslog from 11/6/12

comment:36 Changed 7 years ago by luroh

Blocking: 7665 added

comment:37 Changed 7 years ago by xyzzy

Sorry for the delay in replying. x86_64 is going to be merged soon, once that's finished could you test again? There could have been some problems that got fixed in master that might cause you problems on x86_64.

comment:38 Changed 6 years ago by Luposian

Since the recent merging, now what do I do? Do I download/build Haiku for x86_64, like I used to download/build Haiku for x86? Do I use my recently modified "Haiku x86-64" docs that I sent to you in pastebin? I'm confused as to how to proceed.

I will gladly send you my most recent build instructs in pastebin again, if needed, or maybe you can just review the copy I sent you before and send me your updated version. Hopefully they may only need minor tweaking, if any at all. Not sure.

I have a fresh install of Lubuntu 12.04 on my Acer Aspire X1200 system. Just need proper instructs to go from here.

comment:39 Changed 6 years ago by xyzzy

The procedure to build now is mostly the same as a regular x86 build - clone the main Haiku git repository (no need to checkout x86_64 any more, since it is now in the master branch), then do the same as you would to build a GCC 4 x86 build, except use x86_64 rather than x86 when running configure to build the cross tools. See here: https://www.haiku-os.org/guides/building/compiling-x86_64

comment:40 Changed 6 years ago by Luposian

I've recently (a month ago or so) built Haiku 64-bit in Lubuntu and the .iso image will not boot. I then tried downloading nightly images (YES!) of Haiku 64 (as recently as a week or two ago), and THEY won't boot either! Not .iso. Not Anyboot.

Someone once said something about the burner app (or .iso driver for the app or something) needed to be changed for Lubuntu. Something about a certain type of iso thing wasn't compatible with Haiku.

Any idea what this is about? Is it (still) true?

If I could get a bootable image that I can then INSTALL (Xyzzy... your Anyboot image booted fine, but once I installed it to the hard drive, it crashed), I can probably just create native images (Haiku 64-bit on Haiku 64-bit!) that way and possibly avoid all these non-native OS built Haiku headaches I'm having... maybe?

Changed 6 years ago by Luposian

Attachment: SYSLOG01.TXT added

Syslog from Haiku 64-bit (hrev45222 (nightly)) on 1/31/13

comment:41 Changed 6 years ago by Luposian

Just so we're clear...

1) I formatted my Lubuntu partition as ReiserFS 2) I installed all the files, requested in the installation instructions on the site 3) I installed mkisofs (and removed that other iso version)

Not sure what else I can do, to make my partition and/or OS more Haiku build compliant. I haven't tried building my own copy of Haiku 64-bit yet, but will in the next few days, if that does any good.

comment:42 Changed 6 years ago by Luposian

I think I discovered my problem. I'm not 100% sure, but I think the LG DVD-RW drive I just bought from Best Buy is the problem. When I plugged in an older DVD-ROM drive, the above 64-bit Haiku image (hrev 45222) I complained wouldn't boot, booted perfectly fine! I'm replying from it!

Apart from the fact there are a lot of programs and apps missing from this image, is there an absolutely positive way to confirm this is a 64-bit version of Haiku? Nothing seems to say it anywhere I look. Not in the About, not in WebPositive, nothing. Is there some Terminal command or something that would confirm this for me?

I'd like to be able to use the LG DVD-RW drive, but not sure how anyone would code around it. I can give a model number and anything on the box, but I can't boot this image from it, so I can't locate any particular info on it and my Acer Aspire X1200 only has two SATA ports! One for the DVD drive and one for the hard drive!

I could possible use the SATA cable from the hard drive and put it on the LG DVD-RW drive and see if Haiku can tell me anythingh about that drive, when I boot from the older DVD-ROM drive.

Funny thing... I had a simliar issue with Windows Vista years ago... it wouldn't install from the DVD-ROM drive I had just bought, but booted from another DVD drive I had! Weird!

comment:43 in reply to:  42 Changed 6 years ago by umccullough

Replying to Luposian:

Apart from the fact there are a lot of programs and apps missing from this image, is there an absolutely positive way to confirm this is a 64-bit version of Haiku? Nothing seems to say it anywhere I look. Not in the About, not in WebPositive, nothing. Is there some Terminal command or something that would confirm this for me?

uname -a

comment:44 Changed 6 years ago by Luposian

Ok, I can create working 64-bit Haiku CD .iso images in Lubuntu 12.04. I can BOOT those CD's, using my older DVD-ROM drive. I can INSTALL "Haiku64" on my second partition, from those CD's. But then... a very odd, but interesting "situation" occurs:

I CAN'T use the Haiku Boot options to boot that partition (CRASH @ disk w/ leaf icon). I CAN'T use Grub to boot that partition (CRASH @ disk w/ leaf icon). I CAN'T boot the CD from my LG DVD-RW drive (CRASH @ disk w/ leaf icon), but...

If I simply leave the CD in the LG DVD-RW drive, the Haiku partition boots! And, let me tell you, I have NEVER seen Haiku boot faster... we're talking MAYBE 10 seconds. I kid you not. The entire boot sequence set of icons are ALL lit up instantly and the desktop appears about 3-5 seconds later.

So now comes the big question... WHY? Why does just leaving the CD in the drive make the Haiku partition boot (BLINDINGLY fast!), when nothing else will? Yet, I CAN'T boot that disc from that drive (yet CAN, from the older DVD-ROM drive) and the Haiku partition will NOT boot any other way?

I'm thinking, if I can "install" builds directly to the partition, then I simply use the disc I have to always boot into that partition, but... it's a little bit of a weird "work-around", to keep from having to swap my SATA cables from one drive to the other, over and over (which, I imagine, will eventually wear out either the cables or the ports).

What is needed from me, to help diagnose this situation?

comment:45 Changed 6 years ago by xyzzy

Are there any issues with a 32-bit build? If not can I get a list of loaded kernel add-ons on 32-bit? I wonder if it's due to some driver being missing on 64-bit.

comment:46 Changed 6 years ago by Luposian

What type of Haiku should I download? GCC2 hybrid, or another GCC Type? Or do I have to recompile my build tools to 32-bit and do it all myself?

comment:47 Changed 6 years ago by Luposian

Ok, I downloaded the latest nightly of the GCC2-hybrid Haiku. It only boots on the DVD-ROM drive. If I try to force it to boot on the LG DVD-RW (via Haiku Boot Options), it crashes @ disk w/ leaf icon. I can install it to the partition, but it will not boot in GRUB (crash @ disk w/ leaf icon).

The installer says it installed the boot sector to the partition, but... can you actually DO that (I thought a disk could only have a boot sector on the primary partition)? I have one SATA disk and the primary partition has Lubuntu 12.04 on it. The secondary partition (on that disk) has Haiku. I remember reading something about Haiku having to be installed on the first disk, but don't recall if it could successfully be installed to a non-primary partition on that disk.

Where do I look for this list of loaded kernel add-ons? I may be able to boot the partition the same way I did Haiku64, but haven't tried it yet... that's really the only way I'm aware of.

comment:48 Changed 6 years ago by Luposian

It acts exactly the same. I was able to boot the partition using the CD, but only in the LG DVD-RW drive (and I can only BOOT the CD in the DVD-ROM drive). So 32-bit/64-bit seems to be an irrelevant aspect, as they both behave identically.

So very strange...

comment:49 Changed 6 years ago by xyzzy

Platform: x86-64All
Summary: Haiku (64-bit) crashes at boot on Acer Aspire X1200Haiku crashes at boot on Acer Aspire X1200

comment:50 Changed 6 years ago by xyzzy

I'm not sure what could be causing this, could somebody else take a look at it?

comment:51 Changed 6 years ago by xyzzy

A couple of suggestions from asking on IRC:

  • Can you boot the partition without any DVD drive attached?
  • Is there a BIOS update available? Axel mentioned previously seeing a machine that wouldn't work with Haiku's ATA driver without a BIOS update.

comment:52 Changed 6 years ago by Luposian

I'll try the "no DVD" idea (but I sense it will just boot to Lubuntu on the primary partition). I'll look into a BIOS update, but doubt there will be one, as the Acer Aspire X1200 (Athlon64 X2 5000+ version) is quite old, in computer technology "years".

comment:53 Changed 6 years ago by Luposian

Just looked on Acer's support page... the last BIOS (and all drivers, as well) for the Aspire X1200 Desktop was in 2009. The version number looks familiar, so I'm pretty sure it's already installed. So that avenue is out. The only other one is "no DVD", which I will try tomorrow. I'll also double-check on the BIOS, just to make sure.

comment:54 Changed 6 years ago by Luposian

Ok, big surprise for me... Acer had two BIOS updates and I hadn't downloaded/installed either of them! I just installed the latest one (-B0) and I think there's a change to the SATA section... it now offers IDE mode (no sub-options beyond that, though)!

I tried booting without any DVD drives attached and nothing changed. Still crashed. So I zero'd my drive, installed Windows Vista (just so I could update the BIOS firmware... WHY ME?!?) and then proceeded to boot the hrev45301 CD in my LG DVD-RW drive (in AHCI mode), and it promptly crashed at the 4th icon (really fast this time). So, I switched to IDE mode in the BIOS and the CD boots, but... upon formatting the drive in Haiku and installing it, the system (not a Haiku crash) says there's no bootable partition or something. If I use Acer's F12 Boot Menu to force boot the SATA HD, it says no boot sector found or something! Going back to AHCI doesn't change anything. Same story.

So, I've wrecked everything. Except I have the last, most recent BIOS update for the system. I have no Windows. I have no Lubuntu. I have no Haiku. It's all crunch. I'm going to try to zero the drive again (ah, 40 minutes of waiting!) and see if formatting/installing Haiku will work this time.

IDE mode makes the Haiku CD boot in the LG DVD-RW. That much I now know. Now I'm just trying to get Haiku onto the SATA HD successfully and will have to wait a few days for that, til we get back from our trip.

If anyone has any suggestions/ideas/advice while I'm gone, let me know. I can use all the help I can get!

comment:55 Changed 6 years ago by diver

Looks like you forgot to install the BootManager.

comment:56 Changed 6 years ago by Luposian

So, you think if I run BootMan from the installer, everything will then boot properly? Worth a shot.

comment:57 Changed 6 years ago by AGMS

I had similar problems with real hardware, you need to either make the whole drive a Haiku disk volume (no partition table) or install the BootManager. For some reason the good old MBR doesn't work with Haiku reliably.

More of my Haiku installation story at http://www.haiku-os.org/node/4997 and http://web.ncf.ca/au829/WeekendReports/20121130/InstallingHaikuR1A4.html

comment:58 Changed 6 years ago by umccullough

You change a lot of things at a time, so it's hard to know what's going on ;)

After you "zero the drive" are you putting an intel partition map and MBR back on it? If you don't do this, and you are installing Haiku directly to the raw disk, your BIOS may very well get finicky and refuse to boot it. This is not uncommon, especially among newer machines.

Most MBRs will chainload the first active partition - you won't need "BootMan". If you don't know how to set the "active partition", then I recommend using a boot manager. Haiku's drive setup can install the intel partition map and MBR, but I'm not sure how well it works. FWIW, I usually end up using GRUB since I usually put linux on a partition at the end of my disk anyway.

comment:59 Changed 6 years ago by Luposian

Ok, good news. After a day away, I came back this afternoon and powered up the system and bingo, Haiku boots fine, with Haiku's boot manager installed (it wasn't working when I left, so dunno what happened while the computer was unplugged the whole time). However, it ONLY boots in IDE mode. In AHCI mode, it crashes at the 4th icon. So, at least we have a working setup. Now, I assume we can further work towards AHCI compliance, by submitting another syslog?

I am using hrev45301 of Haiku x86_64. I have the latest/last BIOS installed.

If possible, I'd just as soon create build of "Haiku64" from within Haiku64 (saving myself from having to mess with Lubuntu as a separate step). Since I did a cd-image of Haiku, I assume it doesn't have everything it needs. Where do I go to get all the files and instructions?

comment:60 Changed 6 years ago by xyzzy

The nightlies should have the base development packages installed. If there's anything missing you should be able to install it via installoptionalpackage.

comment:61 in reply to:  59 Changed 6 years ago by axeld

Replying to Luposian:

Now, I assume we can further work towards AHCI compliance, by submitting another syslog?

In case there is a misunderstanding: Haiku is AHCI compliant. Your laptop obviously is not, though; all we can possibly do is to add a work-around for it. We'll just have to find out where the problem is to be able to do so. Looking into Linux or BSD sources might give a clue, though.

comment:62 Changed 6 years ago by Luposian

The Acer Aspire X1200 is not a laptop. Google it. It's a skinny desktop unit (though maybe there is a laptop version of which I am not aware). However, I will assume you are most likely correct in your assumption, since the system is a cheap Acer system and, therefore, likely to not have the most compliant BIOS updates, since systems nowadays are all throw-away technology. 2009-2012 is like... eons in computer terms.

I'd rather find a system (motherboard), Haiku worked properly with, out of the box, rather than try to finagle a "work-around" for the X1200. I guess I should stick to building a system from scratch, rather than buying an OEM system from Best Buy or elsewhere? Not that I bought it for Haiku, but I had it laying around and thought it might be nice to run Haiku64 on.

Last edited 6 years ago by Luposian (previous) (diff)

comment:63 Changed 6 years ago by Luposian

Axeld - I misspoke. When I said "AHCI compliance", I meant making Haiku work with my system's AHCI mode, which it doesn't. And, I think it would be a pointless venture to try and "patch" a workaround, to make it work with my particular system, which would not really make Haiku better, in the overall scheme of things. Unless it was simply an "add-on" that could detect whether or not it needed to be enabled or something. Otherwise, you're (whichever dev assigned to the task) just adding more code to the tree (bloat), for one particular case, which I'm not going to expect. Afterall, how many people actually (still) own an Acer Aspire X1200 anyways?

Thus, unless the "fix" can be enabled in a non-bloat form, I think this ticket should be closed. We've reached the end and it's time to give up the quest. Some systems can work with Haiku natively and others cannot, and I think the best use of dev resources are on making Haiku work with systems as natively as possible, without funky work-arounds. Haiku should only be expected to work with properly built/BIOS'd systems, not cheap OEM systems that people only run Windows on, til the Next Big BSoD (i.e. version of Windows) comes along... agreed?

So, unless you or someone else wishes to actually endeavor to "fix" this minor issue (if possible), then just consider this ticket over and done with. I won't reopen it.

As a parting remark, is there any way to definitively tell if Haiku is using AHCI mode on a SATA hard drive? I'm running my Haiku64 install SATA drive on an old Compaq Presario SR1910NX system and the latest BIOS has no AHCI/IDE option at all. So, assuming the system can/does switch between the two, how do I know which mode Haiku is actually using? Is there a Terminal command for that or is it some line in the SysLog or...?

comment:64 Changed 6 years ago by Luposian

Please close this ticket. This is an issue with the X1200's implementation of AHCI, because even the standard Haiku nightlies crash. As soon as I switch to IDE, they boot fine. As this system is no longer made nor supported (no more BIOS updates), unless a system specific hack can be mustered (and it would only be to make AHCI mode usable, when IDE mode works fine), this particular issue will never be resolved. So, it's just better to close this ticket and proceed with more important endeavors.

comment:65 Changed 6 years ago by xyzzy

Resolution: invalid
Status: reopenedclosed

comment:66 Changed 10 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.