Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8949 closed bug (fixed)

Intel HD audio problem

Reported by: dsjonny Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: Cc: linlongzhou@…
Blocked By: Blocking: #9095
Has a Patch: no Platform: All

Description

I have integrated Intel audio on my board (Intel DH61AG):

  • device/flags: 1
  • device/id: 0x1c20
  • device/interface: 0x0
  • device/subtype: 0x3
  • device/type: 0x4
  • device/vendor: 0x8086
  • device name: 6 Series/C200 Series Chipset Family High Definition Audio

The problem is: there is very bad output. There is sound, but something is hears bad. I have tried to change all thing on the media settings panel, but not helped.

And there is another problem: no HDMI audio output.

I have attached an mp3 file save from the output.

Attachments (3)

Hang002.mp3 (110.2 KB ) - added by dsjonny 7 years ago.
SYSLOG01.TXT (93.4 KB ) - added by dsjonny 7 years ago.
hda-syslog.txt (26.3 KB ) - added by axeld 7 years ago.
Axels syslog hda excerpt

Download all attachments as: .zip

Change History (18)

by dsjonny, 7 years ago

Attachment: Hang002.mp3 added

comment:1 by dsjonny, 7 years ago

One thing: I have found about 2-3 ticket about there is no audio output on Intel HD audio, but I think this problem is not the similar, because I have audio output, but it sound very bad.

comment:2 by anevilyak, 7 years ago

Component: Kits/Media KitDrivers/Audio/HDA
Owner: changed from axeld to korli

comment:3 by mmadia, 7 years ago

Version: R1/alpha4R1/Development

by dsjonny, 7 years ago

Attachment: SYSLOG01.TXT added

comment:4 by dsjonny, 7 years ago

I have attached a syslog file. In the I found that it detects the HDMI as output as well.

And I remember that there was a same problem (the bad sound) on BeOS too, and I could solve it when I changed the multi audio media addon to another. Unfortunatelly I do not remember what files I have changed.

comment:5 by dsjonny, 7 years ago

I remember now: on BeOS the problem was the same, and I replaced the original BeOS multi_audio.media_addon to a haiku cvs version multi_audio.media_addon. That solved my problem. That was a VIA chipset, but the problem was the same. Unfortunatelly that addon is not working with Haiku now.

comment:6 by dsjonny, 7 years ago

It is very strange... If I play a video in MediaPlayer, than if the MediaPlayer is on the top, than I hear just a bit noise, but if it is in full screen mode, than the sound is perfect. If the player is not on the top or in full screen, than when I switch to another window, than the sound will be terrible again.

comment:7 by axeld, 7 years ago

I can also confirm the same oddities here - playing back video considerably improves the sound quality. Changing the workspace causes audio to be bad again. Full screen video makes the sound almost perfect (it only crackles rarely). Amazing. I'm attaching my syslog here as well. Interestingly, I find the same two suspicious lines, too:

hda: DMA position for stream (id:2) seems to be broken. Switching to using LPIB.
hda: DMA position for stream (id:1) seems to be broken. Switching to using LPIB.

by axeld, 7 years ago

Attachment: hda-syslog.txt added

Axels syslog hda excerpt

comment:8 by jrepan, 7 years ago

Constantly moving around a window(for example Terminal) also improves quality. Could it be something related to inter-process communication?

comment:9 by axeld, 7 years ago

Blocking: 9095 added

(In #9095) This sounds a lot like #8949 -- closing as a duplicate.

comment:10 by mshlyn, 7 years ago

Cc: linlongzhou@… added

comment:11 by axeld, 7 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev44757.

At BeGeistert, Marcus made me aware that snooping is only enabled for a specific Intel device -- when I played with that earlier, I did not notice this at all.

in reply to:  11 comment:12 by dsjonny, 7 years ago

Replying to axeld:

Fixed in hrev44757.

At BeGeistert, Marcus made me aware that snooping is only enabled for a specific Intel device -- when I played with that earlier, I did not notice this at all.

Good news! :) Can you add this to the nightly build too? Than I can check it.

in reply to:  11 comment:13 by luroh, 7 years ago

Replying to axeld:

Fixed in hrev44757.

Yes, this got my audio [8086:1c20] working as well (you probably noticed the horrible distorted noise emanating from my laptop at BG). Thanks!

comment:14 by dsjonny, 7 years ago

Perfect! Thank you!

in reply to:  11 comment:15 by Pete, 7 years ago

Replying to axeld:

Fixed in hrev44757.

I'll add my many thanks to Axel here. I've been bashing away at this same problem for months on my ZaReason laptop (where everything Haiku worked beautifully except the HDA sound). Somehow this ticket slipped by me til now, but the symptoms are identical. With this fix, audio is suddenly beautiful too! For reference, the hardware is reported as "7 Series/C210" with codec ALC269VC (from Linux).

Note: See TracTickets for help on using tickets.