Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8955 closed bug (duplicate)

Some program's window cannot show if only one language is preferred

Reported by: dsjonny Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: #8275 Blocking:
Has a Patch: no Platform: All

Description

I have a "strange" problem: If I have only Hungarian language preferred in the Local settings, than the Backgrounds and the ShowImage (or sometimes the StyledEdit) cannot use. The application starts, but no window shown.

I have checked the syslog:

USER 'liblocale.so'[958]: app application/x-vnd.Haiku-DiskProbe send to client failed: Bad port ID
USER 'liblocale.so'[410]: app application/x-vnd.Haiku-WebPositive send to client failed: Bad port ID
Last message repeated 7 times
USER 'liblocale.so'[1041]: app application/x-vnd.Haiku-Backgrounds send to client failed: Bad port ID
USER 'liblocale.so'[1174]: app application/x-vnd.Haiku-Locale send to client failed: Bad port ID
USER 'liblocale.so'[1217]: app application/x-vnd.Haiku-Backgrounds send to client failed: Bad port ID
USER 'liblocale.so'[1287]: app application/x-vnd.Haiku-Backgrounds send to client failed: Bad port ID
USER 'liblocale.so'[1331]: app application/x-vnd.Haiku-Backgrounds send to client failed: Bad port ID
USER 'liblocale.so'[1258]: app application/x-vnd.Haiku-Locale send to client failed: Bad port ID

There are many entries like these. If I have add the US English too as primary preferred, than it works. After I change the preferred languages order, it works again, and sometimes after I remove the English, this is the same.

I tried to fiund out using the debugger application, but I did not found anything.

Change History (4)

comment:1 Changed 7 years ago by diver

Blocked By: 8275 added
Resolution: duplicate
Status: newclosed
Version: R1/alpha3R1/Development

Seems like a dupe of #8275.

comment:2 Changed 7 years ago by leavengood

I would not be so fast to assume it is related to #8275. To me it sounds more like a bug in the Locale Kit.

comment:3 Changed 7 years ago by diver

dsjonny, do you have "Translate application and folder names" option enabled in Locale prefs?
If yes, could you uncheck it and try again? Thanks!

comment:4 in reply to:  3 Changed 7 years ago by dsjonny

Replying to diver:

dsjonny, do you have "Translate application and folder names" option enabled in Locale prefs?
If yes, could you uncheck it and try again? Thanks!

I have unchecked it, and no I have no problem. I have added only the Hungarian language as preferred on the Local panel, and I also rebooted the Haiku. Now everything works fine.

Note: See TracTickets for help on using tickets.