Opened 7 years ago

Closed 6 years ago

#8959 closed bug (fixed)

[Tracker] crashes in strcasecmp ()

Reported by: diver Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev44622, gcc2hybrid in vbox 4.1.22

  1. Mount vbox additions CD.
  2. open /VBOXADDITIONS_4.1.22_80657
  3. select VBoxWindowsAdditions-amd64.exe and press enter
  4. close Open with window using alt+w
  5. repeat 3-4 a couple of times

Tracker either crashes or Open with window appears empty (with no items)

Thread 2434 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Tracker (2430) thread launch looper (2434)]
0x00785320 in strcasecmp () from /boot/system/lib/libroot.so
(gdb) bt
#0  0x00785320 in strcasecmp () from /boot/system/lib/libroot.so
#1  0x00303dd6 in BRoster::_ResolveApp () from /boot/system/lib/libbe.so
#2  0x00303582 in BRoster::_LaunchApp () from /boot/system/lib/libbe.so
#3  0x003017b8 in BRoster::Launch () from /boot/system/lib/libbe.so
#4  0x005d6b1f in BPrivate::_TrackerLaunchDocuments () from /boot/system/lib/libtracker.so
#5  0x006730ea in BPrivate::LaunchLooper::MessageReceived () from /boot/system/lib/libtracker.so
#6  0x002ed5af in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#7  0x002eef1d in BLooper::task_looper () from /boot/system/lib/libbe.so
#8  0x002eeb0b in BLooper::_task0_ () from /boot/system/lib/libbe.so
#9  0x0071d6e3 in thread_entry () from /boot/system/lib/libroot.so
#10 0x78074fec in ?? ()
(gdb)

Change History (3)

comment:1 by diver, 7 years ago

It happens with any unknown file like (e.g. catalog file). I noticed that with every open with window invocation there are fewer and fewer items shown. Maybe at some point it can't compare something and crashes?

comment:2 by stpere, 6 years ago

Hi, can you still reproduce it? I can't reproduce it here..

comment:3 by diver, 6 years ago

Resolution: fixed
Status: newclosed

Can't reproduce either. Closing.

Note: See TracTickets for help on using tickets.