Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8980 closed bug (duplicate)

Haiku hrevr1alpha4-44595 KDL: _mutex_lock(): double lock of 0x8019e000 by thread 15

Reported by: simonsouth Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #8977 Blocking:
Has a Patch: no Platform: All

Description

While using hrev1alpha4-44596 on my Acer AOD250 netbook the KDL shown in the attached screenshot happened several times.

Nothing specific seemed to trigger it, although I happened to be typing in Terminal each time it occurred. Continuing from the debugger appeared to work but (for example) trying to close applications made them seem to hang, and in each case I had to reboot to keep working.

The first part of the text in the screenshot reads:

PANIC: _mutex_lock(): double lock of 0x8019e000 by thread 15
Welcome to Kernel Debugging Land...
Thread 15 "block notifier/writer" running on CPU 0
stack trace for thread 15 "block notifier/writer"
    kernel stack: 0x81199000 to 0x8119d000

Attachments (1)

block-notifier-writer-panic-acer-aod250.jpg (298.9 KB ) - added by simonsouth 7 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 by anevilyak, 7 years ago

Blocked By: 8977 added
Resolution: duplicate
Status: newclosed

Duplicate of #8977.

comment:2 by anevilyak, 7 years ago

Component: - GeneralSystem/Kernel
Note: See TracTickets for help on using tickets.