Opened 7 years ago

Closed 6 years ago

#8979 closed bug (duplicate)

Haiku hrevr1alpha4-44594 KDL (maybe caused by libroot.so)

Reported by: Robert S. Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #9455
Has a Patch: no Platform: All

Description

Got a KDL in Haiku hrevr1alpha4-44594, maybe it is caused by libroot.so but I am not sure.

stack trace for thread 196 "w:123:/boot/home/Desktop"
    kernel stack: 0x81b71000 to 0x81b75000
      user stack: 0x70596000 to 0x705d6000
frame               caller     <image>:function + offset
0 81b74b58 (+  48) 800949e0   <kernel_x86> invoke_command_trampoline( [34m0x81b74bf0 [0m) + 0x001c
1 81b74b88 (+  12) 8012ad86   <kernel_x86>:arch_debug_call_with_fault_handler + 0x001b
2 81b74b94 (+  48) 80093976   <kernel_x86>:debug_call_with_fault_handler + 0x005e
3 81b74bc4 (+  64) 80094c39   <kernel_x86>:invoke_debugger_command + 0x00b9
4 81b74c04 (+  64) 80094a65   <kernel_x86> invoke_pipe_segment(debugger_command_pipe*: [34m0xcce38030 [0m, int32: [34m0 [0m, [34m0x0 [0m [31m"<NULL>" [0m) + 0x0079
5 81b74c44 (+  64) 80094da4   <kernel_x86>:invoke_debugger_command_pipe + 0x009c
6 81b74c84 (+  48) 80096a2c   <kernel_x86> ExpressionParser< [32m0x81b74d34 [0m>::_ParseCommandPipe( [34m0x81b74d30 [0m) + 0x0234
7 81b74cb4 (+  64) 80095c4c   <kernel_x86> ExpressionParser< [32m0x81b74d34 [0m>::EvaluateCommand( [34m0x8019f360 [0m [36m"sc | qrappend" [0m, [34m0x81b74d30 [0m) + 0x02d0
8 81b74cf4 (+ 224) 80098078   <kernel_x86>:evaluate_debug_command + 0x0080
9 81b74dd4 (+  64) 80092216   <kernel_x86> kernel_debugger_loop( [34m0x8016f777 [0m [36m"PANIC: " [0m, [34m0x801516e4 [0m [36m"port %ld: no messages found
" [0m, [34m0x81b74e80 [0m [36m"{ " [0m, int32: [34m1 [0m) + 0x032a
10 81b74e14 (+  48) 8009246b   <kernel_x86> kernel_debugger_internal( [34m0x8016f777 [0m [36m"PANIC: " [0m, [34m0x801516e4 [0m [36m"port %ld: no messages found
" [0m, [34m0x81b74e80 [0m [36m"{ " [0m, int32: [34m1 [0m) + 0x0053
11 81b74e44 (+  48) 80093cf0   <kernel_x86>:panic + 0x0024
12 81b74e74 (+  80) 80063384   <kernel_x86>:_get_port_message_info_etc + 0x02ac
13 81b74ec4 (+  80) 800630c9   <kernel_x86>:port_buffer_size_etc + 0x0025
14 81b74f14 (+  48) 80064271   <kernel_x86>:_user_port_buffer_size_etc + 0x008d
15 81b74f44 (+ 100) 8012bff0   <kernel_x86>:handle_syscall + 0x00cd
user iframe at 0x81b74fa8 (end = 0x81b75000)
eax 0xd4           ebx 0x96cf14        ecx 0x705d5e30   edx 0xffff0114
esi 0xffffffff     edi 0x7fffffff      ebp 0x705d5e5c   esp 0x81b74fdc
eip 0xffff0114  eflags 0x3216     user esp 0x705d5e30
vector: 0x63, error code: 0x0
16 81b74fa8 (+   0) ffff0114   <commpage>:commpage_syscall + 0x0004
17 705d5e5c (+  48) 00490b99   <libbe.so> BPrivate::LinkReceiver< [32m0x186db1b0 [0m>::AdjustReplyBuffer(int64: [34m9223372036854775807 [0m) + 0x0045
18 705d5e8c (+  64) 00490c5b   <libbe.so> BPrivate::LinkReceiver< [32m0x186db1b0 [0m>::ReadFromPort(int64: [34m9223372036854775807 [0m) + 0x003b
19 705d5ecc (+  48) 00490a3f   <libbe.so> BPrivate::LinkReceiver< [32m0x186db1b0 [0m>::GetNextMessage( [34m0x705d5f44 [0m, int64: [34m9223372036854775807 [0m) + 0x0047
20 705d5efc (+ 128) 002a2ab4   <_APP_> ServerWindow< [32m0x186d8e50 [0m>::_MessageLooper( [34m0x0 [0m) + 0x02fc
21 705d5f7c (+  48) 0027f4ac   <_APP_> MessageLooper< [32m0x186d8e50 [0m>::_message_thread(NULL) + 0x0028
22 705d5fac (+  48) 008c96e3   <libroot.so>:_get_next_team_info (nearest) + 0x005f
23 705d5fdc (+   0) 705d5fec   4909:w:123:TrackerWindow_196_stack@0x70596000 + 0x3ffec

Change History (3)

comment:1 Changed 7 years ago by anevilyak

Component: System/libroot.soSystem/Kernel

comment:2 Changed 6 years ago by axeld

Blocking: 9455 added

(In #9455) Please look out for older tickets. This one is a duplicate of #8979 that you reported a few months ago :-)

Also, please always include the original KDL message. If it is scrolled out of sight, you can use the message command to let KDL print it again.

comment:3 Changed 6 years ago by Robert S.

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.