Opened 7 years ago

Closed 5 years ago

#9013 closed bug (invalid)

USB-drive Audio-CD problem

Reported by: dsjonny Owned by: darkwyrm
Priority: normal Milestone: R1
Component: Applications/CDPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Cannot play Audio-CD from USB CD/DVD drive. Haiku can recognize the device, and DATA CD can use, but when I insert Audio-CD, it shows as empty drive.

My drive is: SAMSUNG SE-208AB

Change History (7)

comment:1 Changed 7 years ago by scottmc

what's cdrecord -media-info show when you install an audio cd in that same drive? Also does that same drive play audio CDs in any other OS?

comment:2 Changed 7 years ago by dsjonny

Using Windows, there is no problem with the Audio-CD.

When Audio-CD inserted:

~/Desktop> cdrecord -scanbus
Cdrecord-ProDVD-ProBD-Clone 3.01a07 (i586-pc-haiku) Copyright (C) 1995-2012 Joerg Schilling
Using libscg version 'schily-0.9'.
scsibus0:
        0,0,0     0) *
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) '' '' '' NON CCS Disk
        0,6,0     6) *
        0,7,0     7) *
~/Desktop> cdrecord dev=0,5,0 -checkdrive
Cdrecord-ProDVD-ProBD-Clone 3.01a07 (i586-pc-haiku) Copyright (C) 1995-2012 Joerg Schilling
scsidev: '0,5,0'
scsibus: 0 target: 5 lun: 0
Using libscg version 'schily-0.9'.
cdrecord: Cannot do inquiry for CD/DVD/BD-Recorder.
cdrecord: The unit seems to be hung and needs power cycling.
~/Desktop> cdrecord dev=0,5,0 -media-info
Cdrecord-ProDVD-ProBD-Clone 3.01a07 (i586-pc-haiku) Copyright (C) 1995-2012 Joerg Schilling
cdrecord: WARNING: Cannot set priority on this OS.
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '0,5,0'
scsibus: 0 target: 5 lun: 0
Using libscg version 'schily-0.9'.
cdrecord: Cannot do inquiry for CD/DVD/BD-Recorder.
cdrecord: The unit seems to be hung and needs power cycling.
~/Desktop> 

During the CD is inserted, the drive LED's blinking, but just a bit.

When Data CD inserted the cdrecord output is the same, but the disk has been mounted as an USB drive, and I can use it. In this CD the drive LED is blinking fast and light.

And I have tried DVD movie too, and it was perfect in MediaPlayer (video, 2 audio tracks, subtitles).

(Maybe there is a problem with the scsi driver?)

comment:3 Changed 7 years ago by dsjonny

Version: R1/alpha3R1/Development

comment:4 Changed 6 years ago by dsjonny

Some other info:

Welcome to the Haiku shell.

~> uname -a
Haiku shredder 1 hrev45022 Dec 17 2012 00:44:21 BePC Haiku
~/Desktop> sysinfo
Kernel name: kernel_x86 built on: Dec 17 2012 00:44:21 version 0x1
4 Intel Core™ i3-2100T, revision 86a7 running at 2494MHz (ID: 0x00000000 0x00000000)
~/Desktop> cdrecord -scanbus
Cdrecord-ProDVD-ProBD-Clone 3.01a07 (i586-pc-haiku) Copyright (C) 1995-2012 Joerg Schilling
Using libscg version 'schily-0.9'.
scsibus0:
        0,0,0     0) *
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) '' '' '' NON CCS Disk
        0,6,0     6) *
        0,7,0     7) *
~/Desktop> cdrecord dev=0,5,0 -media-info
Cdrecord-ProDVD-ProBD-Clone 3.01a07 (i586-pc-haiku) Copyright (C) 1995-2012 Joerg Schilling
cdrecord: WARNING: Cannot set priority on this OS.
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '0,5,0'
scsibus: 0 target: 5 lun: 0
Using libscg version 'schily-0.9'.
cdrecord: Cannot do inquiry for CD/DVD/BD-Recorder.
cdrecord: The unit seems to be hung and needs power cycling.
~/Desktop> ls -lsR /dev/disk/usb
/dev/disk/usb:
total 0
0 drwxr-xr-x 1 user root 0 2012-12-22 15:20 0
0 drwxr-xr-x 1 user root 0 2012-12-22 15:20 1
...
/dev/disk/usb/1:
total 0
0 drwxr-xr-x 1 user root 0 2012-12-22 14:22 0

/dev/disk/usb/1/0:
total 0
0 crw-r--r-- 1 user root        0 2012-12-22 14:22 raw
~/Desktop> listusb
...
0e8d:1806 /dev/bus/usb/1/0/3 "MediaTek Inc." "Samsung SE-208AB Slim Portable DVD Writer" ver. 0000
...
~/Desktop> listusb -v
...
[Device /dev/bus/usb/1/0/3]
    Class .................. 0x00 (Per-interface classes)
    Subclass ............... 0x00
    Protocol ............... 0x00
    Max Endpoint 0 Packet .. 64
    USB Version ............ 0x0200
    Vendor ID .............. 0x0e8d (MediaTek Inc.)
    Product ID ............. 0x1806 (Samsung SE-208AB Slim Portable DVD Writer)
    Product Version ........ 0x0000
    Manufacturer String .... "MediaTek Inc"
    Product String ......... "MT1806 "
    Serial Number .......... "R8KN6GAC400KT7 "
    [Configuration 0]
        Configuration String . "Default"
        [Interface 0]
            [Alternate 0 active]
                Class .............. 0x08 (Mass storage)
                Subclass ........... 0x02
                Protocol ........... 0x50
                Interface String ... "6238--Storage"
                [Endpoint 0]
                    MaxPacketSize .... 512
                    Interval ......... 0
                    Type ............. Bulk
                    Direction ........ Input
                [Endpoint 1]
                    MaxPacketSize .... 512
                    Interval ......... 0
                    Type ............. Bulk
                    Direction ........ Output
...
~/Desktop> 

comment:5 Changed 6 years ago by dsjonny

Maybe duplicate of: #4890, #6181

comment:6 Changed 6 years ago by dsjonny

Using hrev46447 nightly anyboot still exists.

comment:7 Changed 5 years ago by waddlesplash

Resolution: invalid
Status: newclosed

CDPlayer doesn't work with most CD drives, especially USB ones. It's been deleted out of Haiku's source tree for this reason in favor of CDDAfs which can play CDs from nearly any drive.

Note: See TracTickets for help on using tickets.