Opened 7 years ago

Closed 7 years ago

#9053 closed bug (duplicate)

[Patch] Download crash due to non-existence of a download folder

Reported by: przemub Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: crash, download Cc:
Blocked By: #8240 Blocking:
Has a Patch: no Platform: All

Description

hrev44684. When I changed a download folder to nonexistent /boot/home/Pobieranie and I tried to download a file downloading stopped at 0% without any alert.

My solution assumes automagical create a folder while settings changes are applied.

Attachments (1)

commit-4910372.patch (1.1 KB ) - added by przemub 7 years ago.

Download all attachments as: .zip

Change History (5)

by przemub, 7 years ago

Attachment: commit-4910372.patch added

comment:1 by przemub, 7 years ago

Has a Patch: set

comment:2 by phoudoin, 7 years ago

Has a Patch: unset

The directory creation should be done in WebKit Haiku's API WebDownloadPrivate class, ideally in findAvailableFilename method, not in Web+ GUI's DownloadWindow. Otherwise, it's indeed the solution.

This ticket is also a duplicate of #8240.

comment:3 by phoudoin, 7 years ago

Also, IIRC, BDirectory's CreateDirectory method don't create missing subdirectories along the path.

Better use create_directory() instead.

comment:4 by phoudoin, 7 years ago

Blocked By: 8240 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.