Opened 7 years ago

Closed 6 years ago

#9070 closed bug (duplicate)

WebPositive incorrectly encodes search queries with non-ASCII characters

Reported by: przemub Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: encoding Google search Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you try to query Google by address bar and your query contains characters with diactrics these characters won't be encoded properly.

For example, phrase "zażółć gęślą jaźń" is converted to: http://www.google.com/search?q=za%C3%85%C2%BC%C3%83%C2%B3%C3%85%C2%82%C3%84%C2%87%20g%C3%84%C2%99%C3%85%C2%9Bl%C3%84%C2%85%20ja%C3%85%C2%BA%C3%85%C2%84 Google interprets it as zażółć gęślą jaźń.

When you enter this phrase directly in Google site, it is converted to: http://www.google.com/search?q=za%C5%BC%C3%B3%C5%82%C4%87+g%C4%99%C5%9Bl%C4%85+ja%C5%BA%C5%84

What is apparently different. It may be related to #9063 ticket.

Change History (1)

comment:1 by pulkomandy, 6 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #7272.

Note: See TracTickets for help on using tickets.