Opened 7 years ago

Last modified 6 weeks ago

#9075 assigned bug

When using cortex, if you disconnect the output from media player, you must restart the media server to make it function again

Reported by: SeanCollins Owned by: nobody
Priority: normal Milestone: R1
Component: Add-Ons/Media/Mixer Version: R1/Development
Keywords: Cc: pete.goodeve@…
Blocked By: Blocking: #12629, #12679
Has a Patch: no Platform: All

Description

If you disconnect the output from media player to the mixer, you must restart the media server and media server add-on to get mediaplayer to work. I am unsure of wether this is a bug in the mediakit or media player, but it also effects other applications like soundplay. I would assume it could be a bug in both the media kit and mediaplyer however. the transport function also seems to cuase problems as well.

hrev44678 gcc2h

Change History (8)

comment:1 Changed 7 years ago by 3dEyes

Restart media services is not required. Enough to make a Stop-Start Transport after reconnecting player to mixer.

comment:2 Changed 7 years ago by SeanCollins

I have to restart the media server when attempting to do anything with cortext that disconnects/reconnects. could this be a driver issue ? I connect/disconnect between the application and the mixer.Disconnecting the mixer from the driver, cuases the same problems however.

Last edited 7 years ago by SeanCollins (previous) (diff)

comment:3 Changed 7 years ago by Pete

I was just about to report much the same bug myself, when I found this recent ticket.

I don't have to restart Media Services to recover -- just close and reopen to source app (MediaPlayer, SoundPlay, whatever) -- but the failure is otherwise the same.

If, in Cortex, I try to disconnect the auto link from source to mixer, and then reconnect it -- to the mixer or anywhere else -- the reconnection is completely dead. I've found no way to revive it; I just have to close the app and start over. Which -- as it automatically re-links to the mixer -- is not much use if I want to drive anything else!

I've tried opening the Cortex Transport window and using the buttons there, but that doesn't work for me. In fact it seems rather confused! Even if the source is playing (through a working link) it's the 'Start' button that's enabled, not 'Stop'. Clicking Start enables Stop, and vice-versa, but otherwise seems to have no effect. Except quite probably locking up Cortex... (:-/)

This is not a new problem BTW. I've tried a few times in the past to, say, connect the synth to SoundRecorder, and failed. [Apologies for not reporting it, but it was tangential at the time.] However it seems to me a fairly major bug, as it negates the whole BeOS MediaKit conception of being able to connect media processors in arbitrary chains! For instance, on BeOS it's trivial to use Cortex to redirect SoundPlay's output to the SoundRecorder. (And also I notice on BeOS that the source keeps playing even when its output is disconnected. In Haiku, cutting the link stops the source.)

As Cortex is the only way I know of to do this sort of thing, I can't tell if the problem is there or more basic to the MediaKit, but the symptoms look more like the latter.

comment:4 Changed 7 years ago by Pete

Cc: pete.goodeve@… added

comment:5 Changed 4 years ago by Barrett

Owner: changed from nobody to Barrett
Status: newassigned

comment:6 Changed 3 years ago by Barrett

Blocking: 12629 added

comment:7 Changed 3 years ago by diver

Blocking: 12679 added

comment:8 Changed 6 weeks ago by korli

Owner: changed from Barrett to nobody
Note: See TracTickets for help on using tickets.