Opened 13 years ago

Closed 11 years ago

#910 closed bug (duplicate)

[Tracker] can't empty trash with cyrillic (at least) characters in filenames

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tracker can't empty trash with cyrillic (at least) characters in file names. When empting Tracker says that it can't delete such files, after that Trash folder becomes empty trash icon, opening trash folder don't show any files, but terminal confirms that in fact files exists there.

Attachments (1)

Trash.zip (31.9 KB) - added by diver 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by axeld

This is probably a duplicate of bug #724. Anyway, can you give an example name that cannot be removed? I could not reproduce bug #724 by just creating such a file under Haiku and removing it then (as this worked fine). Does that work for you, too? Where do those files come from?

comment:2 Changed 13 years ago by diver

Yes, i think it's a dup of bug #724, anyway i'll attach such files with zip archive. These files are from qube.ru maillist made by www.rss2email.ru.

Changed 13 years ago by diver

Attachment: Trash.zip added

comment:3 Changed 13 years ago by axeld

Milestone: R1Haiku R1

comment:4 Changed 12 years ago by axeld

I've downloaded the archive, unzipped it under Haiku directly to the Trash, and deleted them afterwards. Worked just fine. Have you any more insight on how I could reproduce the error you are encountering with the archive you made available?

comment:5 Changed 11 years ago by diver

I'm wondering, could this be fixed by hrev24458 too?

comment:6 Changed 11 years ago by jackburton

Yeah, most probably.

comment:7 Changed 11 years ago by axeld

Resolution: duplicate
Status: newclosed

Duplicate of #724.

Note: See TracTickets for help on using tickets.