Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9123 closed bug (duplicate)

KDL Panic after lots of vm_page_fault

Reported by: fpcmuller Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #5262 Blocking:
Has a Patch: no Platform: All

Description

As a developer of Free Pascal compiler

I am using a Haiku VM to check state of Haiku port of this compiler.

I run nightly tests.

But sometimes the VM crashes, usually after a long series of vm_page_fault due to a test program doing an infinite recursion and thus overflooding the stack area.

I was not able to saved the syslog, but managed to create a few

snapshots with syslog output after reboot.

Pierre Muller

Attachments (7)

Haiku-crash1.jpg (213.6 KB ) - added by fpcmuller 7 years ago.
Haiku-crash2.jpg (191.2 KB ) - added by fpcmuller 7 years ago.
Haiku-crash3.jpg (168.7 KB ) - added by fpcmuller 7 years ago.
Haiku-crash4.jpg (194.1 KB ) - added by fpcmuller 7 years ago.
Haiku-crash5.jpg (175.1 KB ) - added by fpcmuller 7 years ago.
tstack.pp (1.2 KB ) - added by fpcmuller 7 years ago.
Source of the endless test
tstack (349.8 KB ) - added by fpcmuller 7 years ago.
Endlessly running executable (for R1alpha3)

Download all attachments as: .zip

Change History (15)

by fpcmuller, 7 years ago

Attachment: Haiku-crash1.jpg added

by fpcmuller, 7 years ago

Attachment: Haiku-crash2.jpg added

by fpcmuller, 7 years ago

Attachment: Haiku-crash3.jpg added

by fpcmuller, 7 years ago

Attachment: Haiku-crash4.jpg added

by fpcmuller, 7 years ago

Attachment: Haiku-crash5.jpg added

comment:1 by anevilyak, 7 years ago

Blocked By: 5262 added
Component: - GeneralSystem/Kernel
Resolution: duplicate
Status: newclosed
Version: R1/alpha3R1/Development

comment:2 by axeld, 7 years ago

Pierre, how reproducible is this problem for you? And how exactly do you reproduce it? Could you give a short step-by-step description (ie. a package to download, what commands to execute, etc.)? I would love to find another problem causing this bug.

comment:3 by fpcmuller, 7 years ago

The problem seems to arise every few days (maybe a week in average)

on a virtual box running nightly testsuite of free pascal.

The main cause of troubles seems to be a failure of one of the tests,

tstack.pp

http://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/tests/test/tstack.pp?view=markup&pathrev=4565

This test generates on purpose (to check that the exception is correctly handled

by Free Pascal Run Time Library)

but (the RTL is probably faulty here)....

the test leads to an endless series of Kernel generated SIGSEGV.

The kernel crash seem to always follow that problem.

Pierre Muller

comment:4 by axeld, 7 years ago

Pardon my ignorance, but I have never used FreePascal before. Where do I get it? How can I run the test suite?

by fpcmuller, 7 years ago

Attachment: tstack.pp added

Source of the endless test

comment:5 by fpcmuller, 7 years ago

Free pascal is a freeware pascal language compiler also available for Haiku.

http://www.freepascal.org

The source file tstack.pp attached above is the source of the problem.

Nevertheless, compiled with latest release (compiler version 2.6.0),

the test ends as expected with a Run Time Error.

Only with a trunk or fixes compiler or the beta version

available at ftp://ftp.freepascal.org/beta/2.6.2-rc1/i386-haiku, the problem shows up.

Would you be interested in a compiled binary presenting the problem?

Last edited 6 years ago by mmadia (previous) (diff)

in reply to:  5 comment:6 by anevilyak, 7 years ago

Replying to fpcmuller:

Would you be interested in a compiled binary presenting the problem?

That would probably be easiest :) Would such a binary require any additional libraries beyond what comes with the OS?

by fpcmuller, 7 years ago

Attachment: tstack added

Endlessly running executable (for R1alpha3)

comment:7 by fpcmuller, 7 years ago

Endlessly running executable attached, the list of library loaded,

as shown by GNU gdb only lists: runtime_loader, libroot.so,; libnetwork.so, libbe.so and libstdc++.hrev4.so

comment:8 by fpcmuller, 7 years ago

Please note that I am not sure that runnning this single file is enough to generate the kernel problem, the problem always happened within the long testsuite.

Note: See TracTickets for help on using tickets.