Opened 7 years ago

Closed 7 years ago

#9156 closed bug (duplicate)

Bring the window front when one of it's control activated

Reported by: dsjonny Owned by: stippi
Priority: normal Milestone: R1
Component: User Interface Version: R1/alpha4
Keywords: Cc:
Blocked By: #7630 Blocking:
Has a Patch: no Platform: All

Description

I found many times when I click on a control in a window on the background, than it is activated, but not bring it to the front. I meat this when I use for example the WebPositive and ActivityMonitor. I have attached a screenshot about this case. In the image you can see the WebPositive window is active, but not in the front. When I click on the window's tab or the border, than it will bring to front. But if I click on a menu only, or right click on the webpage when the window is in the back, than the window will stay in it's z-position.

Attachments (1)

appserver.png (240.8 KB) - added by dsjonny 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by dsjonny

Attachment: appserver.png added

comment:1 Changed 7 years ago by axeld

Are you intentionally or accidentally using the focus follow mouse mode? What you describe is the very nature of this mouse mode. Unless I misunderstood you, this ticket is invalid; please correct me if I'm wrong.

comment:2 in reply to:  1 Changed 7 years ago by anevilyak

Replying to axeld:

Are you intentionally or accidentally using the focus follow mouse mode? What you describe is the very nature of this mouse mode. Unless I misunderstood you, this ticket is invalid; please correct me if I'm wrong.

The behavior he's describing also happens when not in FFM. If a window overlaps another, and you click on a control in the window below, it's not implicitly brought to the front. I'm not sure if it's always been that way or only since the addition of click-to-focus mode though.

comment:3 Changed 7 years ago by humdinger

Have you by any chance sent the window back by right-clicking it? Happens to me all the time and is quite annoying. See #7630.

comment:4 Changed 7 years ago by dsjonny

I have use the default mouse settings. I know the follow focus settings, but this is not that.

comment:5 Changed 7 years ago by dsjonny

I have checked it on many other windows. If I send the window to the back with right click (the most of the case on the border), the most of the times I can click on the menu, click on the buttons, on the links without bring the widnow to the front. I have tried it with WebPositive, BeZilla, BePDF, WonderBrush and I can reproduce this in all apps. And I tried it on the Tracker too, but there was no "problem".

comment:6 Changed 7 years ago by humdinger

Blocked By: 7630 added
Resolution: duplicate
Status: newclosed

Then it's a duplicate of #7630. Closing ticket. But it sure would be nice to have it fixed...

Note: See TracTickets for help on using tickets.