Opened 7 years ago

Closed 7 years ago

#9157 closed bug (duplicate)

intel_extreme 1 pixel height resolution

Reported by: smoku Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/alpha4
Keywords: 1px Cc: umccullough
Blocked By: #8132 Blocking:
Has a Patch: no Platform: x86

Description

I have exactly the same problem as comment:2:ticket:8001 on both my computers. One is Sony Vaio VGN-Z51WG with Intel GM45 and display of resolution 1600x900@59.9, second is Lenovo IdeaPad S10-3t with GMA 3150 of resolution 1024x600.

I'm seeing a HAIKU logo and icons highlighting, and then 1px height horizontal stripe for ~ 2/3 width of the screen. I see display rendering there and rest of the system is properly booting, just rendering on something like 800x1 resolution. Powering off by pressing power button twice works fine.

I had this bug on Alpha3 and it still exists on Alpha4.

How can I help debugging this issue?

Attachments (5)

IMG_20121114_214006.jpg (958.9 KB ) - added by smoku 7 years ago.
IMG_20121114_214019.jpg (787.0 KB ) - added by smoku 7 years ago.
listdev.gz (827 bytes ) - added by smoku 7 years ago.
syslog.gz (17.9 KB ) - added by smoku 7 years ago.
listimage-drivers.gz (479 bytes ) - added by smoku 7 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by luroh, 7 years ago

A good start would be to provide a syslog, and a photo probably wouldn't hurt either. Except for maybe non-native resolution, booting in failsafe video mode (VESA) works fine, I gather?

by smoku, 7 years ago

Attachment: IMG_20121114_214006.jpg added

by smoku, 7 years ago

Attachment: IMG_20121114_214019.jpg added

comment:2 by smoku, 7 years ago

Photos attached. Booting failsafe video mode works fine.

Is there a way of pulling syslog and listdev dump file off pendrive I have Haiku on from Linux?

by smoku, 7 years ago

Attachment: listdev.gz added

by smoku, 7 years ago

Attachment: syslog.gz added

by smoku, 7 years ago

Attachment: listimage-drivers.gz added

comment:3 by axeld, 7 years ago

A problem like this isn't easy to debug without having the hardware around. Anyway, in the future, please do not archive the files you upload -- this prevents them from being looked at online.

comment:4 by smoku, 7 years ago

Sorry for that. But shouldn't your browser be capable of handling gzipped resources? :-/

Anyway. I am a programmer and I'm willing to spend time debugging this issue. I just need some pointers, to not blindly walk around.

comment:5 by axeld, 7 years ago

The browser might, but Trac doesn't -- it has an embedded preview for types it understands :-)

The source is in src/add-ons/kernel/drivers/graphics/intel_extreme. Besides that, your best resource is http://intellinuxgraphics.org/documentation.html -- I would start looking for differences in the display/memory timing between Haiku, and say Linux. You might also want to try an older version of the driver to see if that makes any difference. Hope that helps you further!

comment:6 by smoku, 7 years ago

I removed intel_extreme driver and intel_extreme.accelerant from /system. Downloaded haiku source, compiled it and symlinked driver and accelerant in proper place in ~/config/add-ons/ hierarchy.

When I boot, I see driver loading, init and then immediately close and uninit.

...
intel_extreme_init() completed successfully!
intel_extreme: accelerant: intel_extreme.accelerant
intel_extreme: close
intel_extreme: intel_extreme_uninit()
...

Any hints?

comment:7 by Sintendo, 7 years ago

I did some testing last summer and had previously reported some of my findings in #8796. According to what I've found, the bug was introduced in hrev42742. You can work around the bug by changing the following piece of code in src/add-ons/accelerants/intel_extreme/mode.cpp in the function intel_set_display_mode from this

if (sanitize_display_mode(target)) {
	TRACE(("intel_extreme: invalid mode set!"));
	return B_BAD_VALUE;
}

to this

sanitize_display_mode(target);

Note that this obviously doesn't fix the underlying issue, which seems to be that the actual sanitizing logic is broken.

comment:8 by umccullough, 7 years ago

Cc: umccullough added

comment:9 by umccullough, 7 years ago

Indeed - removing the return B_BAD_VALUE; from the intel_set_display_mode() as pointed out by Sintendo worked around the issue on my Acer Aspire One AOA150 netbook as well.

comment:10 by diver, 7 years ago

Looks like a dupe of #8132.

comment:11 by axeld, 7 years ago

Blocked By: 8132 added
Resolution: duplicate
Status: newclosed

Indeed, thanks for the hint!

Note: See TracTickets for help on using tickets.